jhgamer

Can't update Display driver :/

Discussion created by jhgamer on May 26, 2015
Latest reply on May 27, 2015 by kingfish

Hi,

 

I don't really get many problems with updating drivers but I've come across a problem in which I can resolve. I currently have 2x R9 290x's and ever since i downloaded the latest 15.4 driver i get a few system crashes so i thought of going back to the 14.12 driver and every time I tried to install it the display driver doesn't install and i get the error MSG "diver install: the diver package is already pre-installed.. so i then went to the device manger and uninstalled the display diver and uninstalled CCC so i rebooted and windows keeps installing the 13.25 driver (driver version: 13.251.9001.1001) automatically.. so i uninstalled it again and got the windows display driver and disconnected any WiFi or Ethernet connections and rebooted... after a reboot no ATI drivers are installed so i go to the "amd-catalyst-omega-14.12-with-dotnet45-win8.1-64bit" application and go on express install and after the installation i got the same error.. I've try manually uninstalling CCC and drivers but windows just wont let me install the 14.12 driver :/

 

I wish to get this solve ASAP.Thanks,

James.

Outcomes