0 Replies Latest reply on May 24, 2015 12:46 PM by lambdafox

    Need Help Configuring Ubuntu 14.10 With Latest Drivers From AMD

    lambdafox

      I have Ubuntu 14.10 amd64 minimal installed with the xubuntu-core.

       

      I have installed the 2:14.501-0ubuntu1 drivers from AMD.

       

      I have 2 Radeon 7970 cards with one monitor connected to each.

       

      After doing the aticonfig -initial -adapter=all , my system is mostly working fine

       

      There are a few quirks that I assume are some configuration I need to do, but as a newbie to linux, I am clueless about.

       

      I am posting here instead of in ubuntu forums, because I have the sense that the stock answer is use nouveau because AMD is soooo terrible, blah blah, blah

       

      Here are quirks I have noticed that I am hoping can help you help me work out the kinks:

       

      • When I try to start xfce4 display settings application, I get a gtk error window with this error:  "unable to start the Xfce Display Settings - Unable to query the version of the RandR extension being used"
      • I have x11-server-utils installed, but when I try xrandr in the terminal, I get this error "RandR extension missing"
      • When I start catfish from the terminal, I see this error in the terminal "** (catfish.py:23037): CRITICAL **: atk_object_set_description: assertion 'ATK_IS_OBJECT (accessible)' failed", but the catfish window opens and seems to work anyway.
      • Now the weirdest one:  I can drag windows between monitors with no errors.  I have not tried every installed application, but palemoon browser, vlc media player, gimp and inkscape all travel without glitches -- with open content inside and with none open inside.  BUT, when I open kodi It works fine on the display attached to ati adapter 0.  When I drag it to the display attached to ati 1, the inside of the window is just empty black space.  Dragging it back to the other monitor and voila it still works as expected.