5 Replies Latest reply on Jun 1, 2015 9:25 AM by tonyhosier

    glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns false

    flynd

      Hi everyone,

      I'm trying to use PerfStudio on my Ogre3D application but I encounter some problem when I pause my application using PerfStudio client.

      My application crashes because glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns GL_FALSE.

      Do you have any idea from where this error could come from (and why only when I try to pause PerfStudio) ?

      Thank you for reading !

        • Re: glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns false
          tonyhosier

          Hi,

           

          PerfStudio may not be handling the Map/Unmap functions correctly in this case. It needs to store buffer data internally so that it can play the frame back repeatedly. How large is the buffer? It's possible that it's running out of memory somewhere. Do you have a test app that we can get hold of to look into this further?

           

          Thanks,

          Tony.

          • Re: glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns false
            Lonesled

            Hi, thanks for the report we will look into it. We will try some Ogre3D apps for a repro case. If you would like us to use your app for the repro  please email a zip file to gordon.selley@amd.com

            • Re: glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns false
              tonyhosier

              Hi Flynd,

               

              A couple questions: Which graphics card/drivers do you have installed? Which version of Ogre are you using? Which OS & version are you using?

               

              Looking at the source code for Ogre 1.8.1 on Windows, Map/Unmap is only used in a couple places when setting up vertex and index buffers. I haven't managed to duplicate what you are seeing with the sample apps that come with Ogre. I'll continue to investigate.

               

              Thanks,

              Tony.

                • Re: glUnmapBufferARB( GL_ARRAY_BUFFER_ARB ) returns false
                  flynd

                  Hi tonyhosier, Lonesled,

                  I have some news :

                  I recently realise that my problem is coming from some fixed-function pipeline's calls. I fixed these ones, and I am now able to pause my application with Perfstudio using Ogre's render system GL3+.

                  But Perfstudio returns another error : "The GPU timing information for the draw calls in this frame cannot be found. The GPU timings displayed will be incorrect, and profiling of draw calls has been disabled." so I can't access to the frame profiler : "Error : Unable to enable selected counters: Hardware not supported".

                  Thank you for your answers,

                  Flynd

                  OS : Linux Mint 17.1

                  Ogre : 1.9

                  gpu : GTX960

                  1 of 1 people found this helpful