3 Replies Latest reply on Apr 23, 2015 9:17 AM by qizhu.cs

    Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher

    qizhu.cs

      I encounter a problem when I execute program from AMD SDK 3.0 on Ubuntu 14.04.

       

      The clinfo reports is attached.

       

      I am sure that A8-7600 is OpenCL 2.0 supported device. However, when I execute the programs SVMBinaryTreeSearch and DeviceEnqueueBFS, it shows Expected Error: Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher. Does anybody know how to fix this?

       

      BTW, the driver I installed is from the package linux-amd-14.41rc1-opencl2-sep19.zip, which is downloaded from AMD OpenCL™ 2.0 Driver