AnsweredAssumed Answered

Internal Error : failed to find as

Question asked by mjw on Jan 26, 2015
Latest reply on Feb 6, 2015 by dipak

I am trying to install AMD APP SDK 2.9.1 on Linux (RHEL 7), initially just for the CPU device; I plan to test with Radeons once that is working. I followed the instructions for 'non-root installation'. The HelloWorld sample works but none of the other samples work; they all fail with a log similar to;

 

Selected Platform Vendor : Advanced Micro Devices, Inc.
Device 0 : Intel(R) Xeon(R) CPU E7- 4870  @ 2.40GHz Device ID is 0x238a590

                        BUILD LOG
************************************************
Internal Error: Failed to find as

Codegen phase failed compilation.

************************************************

 

I have checked that LD_LIBRARY_PATH includes AMDAPPSDK-2.9-1/lib/x86_64 and that AMDAPPSDKROOT and OPENCL_VENDOR_PATH are set appropriately. What else can I do to make this SDK work? I have tried JOCL as well but all of the examples fail with the same error, even HelloJOCL. I can't find much on the web about 'Internal Error: failed to find as'; I assume some OpenCL libraries are loading ok, sufficient to get the platform list, but not to compile a kernel.

Outcomes