4 Replies Latest reply on Sep 11, 2014 9:03 AM by dipak

    CodeXL and VS 2013/14 Crash On Compile

    xsjado

      uint constant lol[32] = { 1,1,1,1, 1,1,1,1, 1,1,1,1, 1,1,1,1, 1,1,1,1, 1,1,1,1, 1,1,1,1, 1,1,1,1 };

       

      __kernel void TestCrash(__global uint *keys)

      {

        uint pos = get_global_id(0);

       

        keys[pos] = lol[pos];

      }

       

      Here is the source, this crashes my display driver running Catalyst 14.4 and 14.7 RC3. I recently rebuilt my dev machine and cannot get past this as using a look-up is a basic requirement of my application.

       

      The only difference I can see apart from driver versions is the use AMD APP SDK 2.9.1, however I put my old HDD in and installed this version and never encountered these problems.

       

      Obviously this snippet is reduced as far as it can go, but these issues are affecting the running of code on the R9 295X2 that is unhooked from any displays. When I tried to build this kernel with that particular adapter running a monitor it resulted in an instantaneous hard reset.cc

       

      Attached is all relevant info. I'm a bit stuck here, and am unable to progress my project any further until I get a resolution, so any help would be much appreciated.

        • Re: CodeXL and VS 2013/14 Crash On Compile
          xsjado

          Anybody looked at this at all? Anyone else come across something similar?

           

          I'd really like to get past this, but it's such an integral part of the application that I cannot.

            • Re: CodeXL and VS 2013/14 Crash On Compile
              dipak

              Hi,

              Sorry for this delayed reply.

              I tried to compile this kernel code using following setups, but couldn't find any issue.

              Card: as don't have the R9 series card, I used HD 7770 and HD  8670D

              Driver: catalyst 14.7 (14.30-140819a-174992E-ATI)

              SDK 2.9. and 2.9.1

              Windows 7 (64bit)

              Code XL 1.4 and VS12

               

              Also I tried to compile this with  fglrx 14.40-140806a-175177E , Pitcairn HD 7870, Ubuntu 14.04  LTS (64bit), SDK 2.9; but worked fine.

               

              Is this related to that R9 series card only? Did you try to build the same on other cards or drivers? Did they work?

              I would the helpful if you provide some extra guidance to reproduce the issue.

               

              Regard,

                • Re: CodeXL and VS 2013/14 Crash On Compile
                  xsjado

                  As I explained in the original post, this only happens with the R9 295X2, I'm currently continuing development on the R9 290Xs that I have here, but they aren't the hardware we are looking at getting for the systems being leveraged for compute purposes.

                   

                  I've attached the image that shows it compiling fine until it reaches "Hawaii", which is the core in the 295X2, I've also attached the NFO that shows my system configuration, where I drive my screens using firepro cards with the 295x2 not attached to a screen (it was hard resetting the machine when it was plugged in).

                   

                  Is there a way for me to step through the compiler and fix this myself?

                    • Re: Re: CodeXL and VS 2013/14 Crash On Compile
                      dipak

                      Hi,

                      Unfortunately I don't have the R9 295X2 card. As you've said, you are working on R9 290X, I guess it is based on Hawaii. Is it working fine on it?  With my above setup, the kernel seems building fine for Hawaii using CodeXL (see attached file). As I've found from your system info that your driver version was 14.10. Please can you check with latest driver? If the issue is related to Hawaii, I'll try to manage a Hawaii card (may be Hawaii Pro) to test it.


                      Regards,