0 Replies Latest reply on Aug 4, 2014 9:33 AM by msoos

    Muxless intel+AMD HD 7600M does not work (Ubuntu 14.04)

    msoos

      Hi,

       

      I have Ubuntu 14.04 installed with latest 14.6 Beta drivers (linux-amd-catalyst-14.6-beta-v1.0-jul11.zip) and I have set the discrete GPU to be active:

       

      $ amdconfig --pxl        

      PowerXpress: Discrete GPU is active (High-Performance mode)

       

      Unfortunately, I get this message in the Xorg log:

       

      [   126.252] (--) fglrx(0): Chipset: "AMD Radeon HD 7600M Series" (Chipset = 0x6840)

      [   126.252] (--) fglrx(0): (PciSubVendor = 0x1028, PciSubDevice = 0x056e)

      [   126.252] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD

      [   126.252] (--) fglrx(0): Linear framebuffer (phys) at 0xa0000000

      [   126.252] (--) fglrx(0): MMIO registers at 0xc2000000

      [   126.252] (--) fglrx(0): I/O port at 0x00004000

      [   126.252] (==) fglrx(0): ROM-BIOS at 0x000c0000

      [   126.258] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

      [   126.258] (EE) fglrx(0): Invalid video BIOS signature!

      [   126.258] (EE) fglrx(0): GetBIOSParameter failed

      [   126.258] (EE) fglrx(0): PreInitAdapter failed

      [   126.258] (EE) fglrx(0): PreInit failed

      [   126.258] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === end

      [   126.262] (II) UnloadModule: "fglrx"

       

      (full log attached) This I believe indicates that switching to the discrete system did not work out, and X gave up. Can you tell me what kind of information you need to debug this and how can I help? I have a Dell Vostro 3560 that is apparently a so-called MUX-less system, i.e. I cannot choose in the BIOS which GPU is active, and I am suppose to choose that using "amdconfig --px-command" which I did as shown above.

       

      Thanks for the help,

       

      Mate Soos