1 Reply Latest reply on Jun 17, 2014 4:20 AM by josefweinbub

    13.352.1009 for W9000 on OpenSuse 13.1 64 bit: No libOpenCL.so?

    josefweinbub

      Hi,

       

      the latest FirePRO driver for Linux 64 bit (13.352.1009) does indeed support OpenSuse 13.1 64 bit.

      However, no suitable libOpenCL.so is installed, only libOpenCL.so.1, which does not work linking against OpenCL (just for the sake of it, I created a symbolic link from /usr/lib/libOpenCL.so.1 to /usr/lib/libOpenCL.so) applications as the linker complains (no surprise here):

       

      /usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libOpenCL.so when searching for -lOpenCL

      /usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: cannot find -lOpenCL

      collect2: error: ld returned 1 exit status

       

      Executing 'clinfo' correctly lists the W9000 and the AMD CPU of the system (output attached to this post).

       

      I have installed the driver manually according to the guide here [1]. The install log (attached to this post) did not reveal any errors during the installation.

       

      Is there something I have overlooked? Any advice?

       

      Thanks!

       

      Best, Josef

       

      [1] SUSE/openSUSE - cchtml.com

       

      System Stats:

      --------------------------

      Linux distribution: OpenSuse 13.1 64 Bit

      Kernel: 3.11.10-11-desktop

      GCC: 4.8.1

      GLIBC: 2.18

      CPU: AMD Phenom II X4 955

      Memory: 8GB

      Mainboard: ASUS M4A79T Deluxe

      Graphics adapter: AMD FirePro W9000