AnsweredAssumed Answered

lokixml.sh in Linux 16.6 drivers

Question asked by VincentSC on Jun 10, 2014
Latest reply on Jan 24, 2015 by b.stolk

There is a problem running lokixml.sh in the 16.6 drivers on Ubuntu 13.10 64 bit.

./lokixml.sh: 143: ./lokixml.sh: [[: not found

 

The solution is in the comments of How to install AMD graphics drivers on Ubuntu - YouTube by Scott Walter:

I think I found the solution.  I'm also on Ubuntu 14.04, attempting to install the fglrx-14.20 and received the exact same error.

 

First, extract the .run file:
     ./amd-driver-installer-14.20-x86.x86_64.run --extract

 

Next, cd into the newly created directory
    cd fgrlx-install
    # optionally, run this to preview the line which is causing the error:
    grep -n "\[\[" lokixml.sh

 

Now, open lokixml.sh in your preferred editor and search for "[[" (without quotes).  Given that we're working with exactly the same version, you should find this on line 143.  Comment out the entire conditional block (lines 143-145).

 

Finally, run the install script with sudo:
    sudo ./ati-installer.sh 14.20 --install
It seems to do something for OpenCL-settings. Could this be fixed in the official download?

Outcomes