3 Replies Latest reply on Jun 18, 2014 2:42 AM by pinform

    AMD App SDK and ATI Mobility Radeon HD 5450

    arrabal

      I've downloaded the latest version (2.9) of the AMD App SDK with the intent of developing and running OpenCL based programs on my laptop's GPU. This laptop is a Dell Inspiron 1564, with Windows 7 x64 and an integrated Ati Mobility Radeon HD 5450 video adapter with 1GB RAM. I installed Visual Studio 2010 and tried to run the sample OpenCL projects included in the SDK, compiling was ok but all of them threw an execution error: "clGetPlatformIDs failed. Error code : CL_PLATFORM_NOT_FOUND_KHR". So, created a new project and compiled a minimal code which consisted in a call to clGetPlatformIDs, that always returned -1001.

       

      I swear I've been googling and trying things for hours without any success. I tried updating catalyst, but the latest version (14) doesn't seem to offer drivers for my video card.  Version 13.12 installed a new driver, but nothing changed.In the page where I downloaded the SDK, it was stated that my GPU was supported for OpenCL programming. In other sites It is said that it supports only ATI Stream SDK 2.3 (which I cannot found anywhere), and in others they said it doesn't support OpenCL at all. In some forum threads they spoke about idc registration, but I don't think it is related. Also, following a suggestion I found, I installed and launched GPU-Z, according to which my card does not support OpenCL.

       

      At this point I am completely lost and clueless. I refuse to accept that my laptop's GPU does not support OpenCL because I found a couple sites (including AMD SDK download site), it is stated the opposite. I will appreciate any help or suggestion on this issue.

       

      Thanks in advance.