2 Replies Latest reply on Apr 29, 2014 6:57 AM by atacama

    Debian Linux (Jessie): System module .. not found

    atacama

      Hi,

      After switching from Ubuntu 13.10 to Debian Testing, CodeXL gives me:

       

      Technology Monitor failure: System OpenGL module not found.

       

      After having set LIBGL_DRIVERS_PATH to the path of the (real, not symlinked) GL library, I get

       

      OpenGL Render Context 1 Created

      ...

      Technology Monitor failure: System OpenCL module not found.

       

      It appears that CodeXL is able to locate the OpenGL library now, but cannot find OpenCL anymore.

      I noticed that in my configuration, GL and CL libs have been installed in different directories:

       

      /usr/lib/x86_64-linux-gnu/libGL.so.1: symbolic link to `/etc/alternatives/glx--libGL.so.1-x86_64-linux-gnu'

      /etc/alternatives/glx--libGL.so.1-x86_64-linux-gnu: symbolic link to `/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1

      /usr/lib/x86_64-linux-gnu/libOpenCL.so.1: symbolic link to `libOpenCL.so.1.0.0'

       

      I tried different ICD loaders and CodeXL versions, no change.

      Unlike ubuntu  (which did work fine, even without GPU from AMD),

      on debian multiple symlink have to be followed to find these libs.

      Maybe it is because of that?

       

      Thank you for your help,

       

      Greetings, Andreas

        • Re: Debian Linux (Jessie): System module .. not found
          Gilad.Yarnitzky

          Debian Linux is not a CodeXL supported platform so there are problems but I'll try to offer some work arounds

           

          1: Are you using CodeXL 1.4? Using CodeXL 1.4 will eliminate the need for OpenCL libraries when debugging OpenGL applications.

          2: Due to the nature of how the driver is installed try pointing the LIBGL_DRIVERS_PATH to a subfolder where libOpenGL/libOpenCL are installed. i.e if the folder is /usr/lib/x86_64-linux-gnu try setting to /usr/lib/x86_64-linux-gnu/testfolder (and of course make sure that the testfolder exists). If I remember correctly you can define in LIBGL_DRIVERS_PATH both path to your libOpenGL and libOpenCL separate the paths by ';'

           

          Hope this helps

          1 of 1 people found this helpful
            • Re: Debian Linux (Jessie): System module .. not found
              atacama

              1. Yes, I am using version 1.4.

              2. I found out that CodeXL writes a logfile. .  Taking a look at CodeXLServer-xxx.log it appears that the OpenCL lib is being looked for in /usr/lib64/libOpencl.so(.1), no matter what i do with LIBGL_DRIVERS_PATH.

              So I made a symlink there from /usr/lib/x86_64-linux-gnu/libOpenCL.so.1 , and the problem is solved.

              Also debugging of cl code works as fine as before.