4 Replies Latest reply on Apr 29, 2014 7:19 PM by obara

    Help A10-7850A trouble

    obara

      As goal to the faster calculation,

      I start to use A10-7850A and make OpenCL program for A10-7850A.

       

      In the case of CL_DEVICE_TYPE_CPU, the program runs very well,

      but in the case of CL_DEVICE_TYPE_GPU, HOST can't find "GPU" at clGetPlatformIDs.

      I think that I miss someting to need to be installed, but I can't find.

       

      APU(CPU/GPU):AMD A10-7850A

      OS: CentOS 6.5

      AMDAPPSDK: AMD-APP-SDK-v2.9-lnx64

      Installed drivers:

          amd-catalyst-14-4-linux-x86-x86-64  or

          amd_13.30_rc3_linux_jan13_2014

        • Re: Help A10-7850A trouble
          sudarshan

          Hi,

          Can you run clinfo (this should be in your /usr/bin as a part of app sdk installation) and check if it is finding GPU device?

            • Re: Help A10-7850A trouble
              obara

              Hi sudarshan

              Thank you for your reply.

              I got the following by "./clinfo" and I confirmed there is GPU device.

              But I can't understand reason why OpenCL can't find GPU device when executing clGetPlatformIDs API.

               

              Any advice is appreciated.

               

              -------------------------------------------------------------------------------------

              # ./clinfo

              Number of platforms: 1
                Platform Profile: FULL_PROFILE
                Platform Version: OpenCL 1.2 AMD-APP (1445.5)
                Platform Name: AMD Accelerated Parallel Processing
                Platform Vendor: Advanced Micro Devices, Inc.
                Platform Extensions: cl_khr_icd cl_amd_event_callback cl_amd_offline_devices cl_amd_hsa

               

                Platform Name: AMD Accelerated Parallel Processing
              Number of devices: 2
                Device Type: CL_DEVICE_TYPE_GPU
                Device ID: 4098
                Board name: AMD Radeon(TM) R7 Graphics
                Device Topology: PCI[ B#0, D#1, F#0 ]
                Max compute units: 8
                Max work items dimensions: 3
                  Max work items[0]: 256
                  Max work items[1]: 256
                  Max work items[2]: 256
                Max work group size: 256
                Preferred vector width char: 4
                Preferred vector width short: 2
                Preferred vector width int: 1
                Preferred vector width long: 1
                Preferred vector width float: 1
                • Re: Help A10-7850A trouble
                  sudarshan

                  Since it is an APU, both CPU and GPU are on same platform (there should be only one platform). You should query devices (clGetDeviceIDs()) to get all the devices on this platform. This should list both CPU and GPU.

                    • Re: Help A10-7850A trouble
                      obara

                      Hi Sudarshan

                      Thank you for your kindly reply.

                       

                      I'm terribly sorry. I have a mistake.

                      I solved the trouble by myself.

                      The trouble was caused by missing to install

                      Catalyst driver "Generate Distribution Specific Driver Package".

                      After installing it, the trouble was solved.

                       

                      Thank you so much