3 Replies Latest reply on Apr 3, 2014 1:33 PM by enricogp

    Amd driver causes notebook to don't wake up from sleep mode

    enricogp

      I noted that after installing windows 8.1 and 2 or 3 programs, whenever my notebook goes into sleep mode it can't "wake up" from it unless I turn it off by the power button (it would stay "sleeping" indefinitely.

       

      I didn't know if it was amd driver fault, but I searched for help and found this:

       

      (By Madeni K N, Microsoft forum moderator)

      Hi,

       

      I got the files you uploaded. Apparently, the crash is a Blue Screen error caused by the atikmpag.sys driver file that is associated to the drivers for your AMD Graphics Card. The bugchek is SYSTEM_SERVICE_EXCEPTION (3b) which means that while handling a System Service routine, something went wrong. Here is the analysis output for the minidump that you uploaded:

       

      *****************************************************************************************************************

       


      Microsoft (R) Windows Debugger Version 6.3.9600.16384 AMD64
      Copyright (c) Microsoft Corporation. All rights reserved.


      Loading Dump File [<File Path>\032214-38968-01.dmp]
      Mini Kernel Dump File: Only registers and stack trace are available


      ************* Symbol Path validation summary **************
      Response                         Time (ms)     Location
      Deferred                                       SRV*http://msdl.microsoft.com/download/symbols
      Symbol search path is: SRV*http://msdl.microsoft.com/download/symbols
      Executable search path is:
      Windows 8 Kernel Version 9600 MP (4 procs) Free x64
      Product: WinNt, suite: TerminalServer SingleUserTS Personal
      Built by: 9600.16452.amd64fre.winblue_gdr.131030-1505
      Machine Name:
      Kernel base = 0xfffff803`3d470000 PsLoadedModuleList = 0xfffff803`3d734990
      Debug session time: Sat Mar 22 08:28:09.534 2014 (UTC - 7:00)
      System Uptime: 0 days 0:31:17.394
      Loading Kernel Symbols
      .

      Press ctrl-c (cdb, kd, ntsd) or ctrl-break (windbg) to abort symbol loads that take too long.
      Run !sym noisy before .reload to track down problems loading symbols.

      ..............................................................
      ................................................................
      .................................
      Loading User Symbols
      Loading unloaded module list
      ............
      *******************************************************************************
      *                                                                             *
      *                        Bugcheck Analysis                                    *
      *                                                                             *
      *******************************************************************************

      Use !analyze -v to get detailed debugging information.

      BugCheck 3B, {c0000005, fffff80001e7a496, ffffd000215b1d60, 0}

      *** WARNING: Unable to verify timestamp for atikmpag.sys
      *** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
      Probably caused by : atikmpag.sys ( atikmpag+20496 )

      Followup: MachineOwner
      ---------

      1: kd> !analyze -v
      *******************************************************************************
      *                                                                             *
      *                        Bugcheck Analysis                                    *
      *                                                                             *
      *******************************************************************************

      SYSTEM_SERVICE_EXCEPTION (3b)
      An exception happened while executing a system service routine.
      Arguments:
      Arg1: 00000000c0000005, Exception code that caused the bugcheck
      Arg2: fffff80001e7a496, Address of the instruction which caused the bugcheck
      Arg3: ffffd000215b1d60, Address of the context record for the exception that caused the bugcheck
      Arg4: 0000000000000000, zero.

      Debugging Details:
      ------------------


      EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

      FAULTING_IP:
      atikmpag+20496
      fffff800`01e7a496 448b9128010000  mov     r10d,dword ptr [rcx+128h]

      CONTEXT:  ffffd000215b1d60 -- (.cxr 0xffffd000215b1d60;r)
      rax=ffffd000215b27c4 rbx=ffffd000215b2840 rcx=0000000000000000
      rdx=0000000000000000 rsi=00000000000000a8 rdi=0000000000024020
      rip=fffff80001e7a496 rsp=ffffd000215b2798 rbp=00000000c0000001
      r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
      r11=fffff80001eae60f r12=0000000000000001 r13=0000000000000000
      r14=0000000000000000 r15=000000000000003a
      iopl=0         nv up ei pl zr na po nc
      cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
      atikmpag+0x20496:
      fffff800`01e7a496 448b9128010000  mov     r10d,dword ptr [rcx+128h] ds:002b:00000000`00000128=????????
      Last set context:
      rax=ffffd000215b27c4 rbx=ffffd000215b2840 rcx=0000000000000000
      rdx=0000000000000000 rsi=00000000000000a8 rdi=0000000000024020
      rip=fffff80001e7a496 rsp=ffffd000215b2798 rbp=00000000c0000001
      r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
      r11=fffff80001eae60f r12=0000000000000001 r13=0000000000000000
      r14=0000000000000000 r15=000000000000003a
      iopl=0         nv up ei pl zr na po nc
      cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
      atikmpag+0x20496:
      fffff800`01e7a496 448b9128010000  mov     r10d,dword ptr [rcx+128h] ds:002b:00000000`00000128=????????
      Resetting default scope

      CUSTOMER_CRASH_COUNT:  1

      DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

      BUGCHECK_STR:  0x3B

      PROCESS_NAME:  chrome.exe

      CURRENT_IRQL:  0

      ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

      LAST_CONTROL_TRANSFER:  from fffff80001e7a55d to fffff80001e7a496

      STACK_TEXT: 
      ffffd000`215b2798 fffff800`01e7a55d : ffffd000`215b2840 00000000`00024020 00000000`00000000 ffffc000`03538720 : atikmpag+0x20496
      ffffd000`215b27a0 ffffd000`215b2840 : 00000000`00024020 00000000`00000000 ffffc000`03538720 00000000`00000048 : atikmpag+0x2055d
      ffffd000`215b27a8 00000000`00024020 : 00000000`00000000 ffffc000`03538720 00000000`00000048 00000000`00000000 : 0xffffd000`215b2840
      ffffd000`215b27b0 00000000`00000000 : ffffc000`03538720 00000000`00000048 00000000`00000000 000000a8`00024020 : 0x24020


      FOLLOWUP_IP:
      atikmpag+20496
      fffff800`01e7a496 448b9128010000  mov     r10d,dword ptr [rcx+128h]

      SYMBOL_STACK_INDEX:  0

      SYMBOL_NAME:  atikmpag+20496

      FOLLOWUP_NAME:  MachineOwner

      MODULE_NAME: atikmpag

      IMAGE_NAME:  atikmpag.sys

      DEBUG_FLR_IMAGE_TIMESTAMP:  52a231d9

      STACK_COMMAND:  .cxr 0xffffd000215b1d60 ; kb

      FAILURE_BUCKET_ID:  0x3B_atikmpag+20496

      BUCKET_ID:  0x3B_atikmpag+20496

      ANALYSIS_SOURCE:  KM

      FAILURE_ID_HASH_STRING:  km:0x3b_atikmpag+20496

      FAILURE_ID_HASH:  {134d7887-18f0-c1c5-5756-f908760f8180}

      Followup: MachineOwner
      ---------

      1: kd> lmvm atikmpag
      start             end                 module name
      fffff800`01e5a000 fffff800`01efa000   atikmpag T (no symbols)          
          Loaded symbol image file: atikmpag.sys
          Image path: \SystemRoot\system32\DRIVERS\atikmpag.sys
          Image name: atikmpag.sys
          Timestamp:        Fri Dec 06 12:21:45 2013 (52A231D9)
          CheckSum:         0009FEFF
          ImageSize:        000A0000
          Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4

       

      **************************************************************************************************************

       

      I would suggest you to uninstall the AMD graphics drivers from your computer and then download and install the latest drivers applicable for your card released by AMD. Download the drivers by putting up appropriate filters here:

       

      http://support.amd.com/en-us/download

       

      Once you have installed the driver, check if the issue persists. If it still persists in the computer, please provide the file I requested now in the Private Message.

       

      Keep us posted on the status of the issue, we will be glad to be of assistance.

       

      Regards-

       

                                              

                                                 Is there any way to fix this?