AnsweredAssumed Answered

fglrx impossible with asus r9 280x

Question asked by dstanescu on Mar 6, 2014
Latest reply on May 5, 2014 by motionpotion

Hi, i own 2x Asus r9 280x (r9280x-dc2-3gd5) which i'm trying to install the drivers on linux, for about 1 week (16-18h/day).

I tried everything i could think of with no success.

 

I tried Catalyst: 13.1, 13.4, 13.11-b9.4, 13.11-b9.95, 13.12, 14.1-b1.3, 14.2-b1.4 (the latest beta)

on almoast every linux distro: Ubuntu 11.04/11.10/12.04/12.10/13.04/13.10/14.04, Fedora 18/19/20, CentOs 6.3/6.4/6.5, RedHat 6.5, Debian 6.0/7, Suse 11, OpenSuse 13

and no success, only a lot of wasted time.

 

What happens watching xorg.log: sometimes fglrx crashes, sometimes it just hangs with no output, sometimes recognizes 1 card and with the other it hangs again and other times no errors nothing but xorg doesn't start, he hangs too.

I tried everything including some patches to fglrx found on google nothing. On each distro i tried each version of catalyst. The same system (hardware+software) works with another card for ex r9 290 but not with this 280x. On the same system i installed windows and saw the drivers works as expected (so no hardware issue, the only cause is fglrx) but on linux what is happening? The drivers aren't updated/fixed in both places? The open source drivers from Ubuntu for ex works (are not good for me, i need fglrx) but if i try to install the proprietary drivers from them again doesn't work. So fglrx it just doesn't want to work with this card!

 

If anybody can help me in some way with a solution pls, i'm desperate!

 

It's impossible for me to understand how a huge company like Amd which is nr 1 on gpu's and not only doesn't have working drivers for his chips.

How we (consumers) are supposed to use them? I spent a lot of money on this boards and i'm only staring at them. Big disappointment!

Outcomes