4 Replies Latest reply on Mar 5, 2014 11:24 AM by fenglee423

    Installing issue of OpenCL on AMD R9 290X in Linux

    fenglee423

      Hi All,

       

      I have just got an ASUS AMD R9 290X board and I am planing to do some OpenCL projects. After I plug in the board to my CentOS 6.5 machine, without driver, it shows PCIe Gen3 x16 connection using "lspci". After installing drivers (I tried both stable and beta) and reboot, the card is then reported as Gen1 x1. I was told it could be the "power saving mode", then I tried "glxgears" which should kickoff the GPU, but sadly it still shows Gen 1 connection. The most confusing thing is I tried "clinfo", it is reporting an AMD platform, but reporting 1 device, CL_DEVICE_TYPE_CPU, which is my Intel i7-4770.

       

      I am not sure if I have missed anything during my installation. Has anyone seen this issue before? Any suggestions are appreciated.

       

      Note: I have tried the latest SDK, since I believe SDK only installs OpenCL drivers for cpu, I do not think this issue is related to SDK.

       

      -Shan