AnsweredAssumed Answered

Help with ADL, ADL_Adapter_Crossfire_Caps returns a error

Question asked by blakey on Feb 14, 2014

Hello,

I'm following ADL sample from ADL SDK and have changed it a bit to show me available crossfire configurations for each different adapter ID, and set the preferred configuration (not shown in code).

Nopaste - powered by project-mindstorm IT Services

but using Catalyst 13.12 or 14.1 beta the ADL_Adapter_Crossfire_Caps returns -1 on all adapters (see output here: http://nopaste.info/f244e39a78_nl.html)

 

And this works with Catalyst 13.4 64bit, but doesn't with 13.12 or 14.1. Win7 pro 64bit.

My goal is to use ADL_Adapter_Crossfire_Set to set crossfire on/off from code.

 

With one adapter on 14.1 beta I get:

[CODE]

D:\Downloads\IDM\Compressed\ADL_SDK_6.0\Sample\Debug>ADL_Sample.exe

Mum adapters! 6

0/0: Adapter name: AMD Radeon HD 6900 Series

0, Adapter name id: 33798080

ADL_Adapter_Crossfire_Caps: ( -1 = ADL_ERR : Generic Error. Most likely one or more of the Escape calls to the driver failed! )

[/CODE]

Even if it's not supported anymore (why would they limit it?) shouldn't it return "not supported" instead of "general error"?

I tried to compile both for 64bit and 32bit so it will load xx and xy version of ADL SDK and both with the same result.

 

Thanks ahead,

Paul.

Outcomes