AnsweredAssumed Answered

Opengl Shader Compiler issues with newer than 13.9 drivers on HD 5850

Question asked by kingbadger3d on Feb 14, 2014
Latest reply on Feb 17, 2014 by kingbadger3d

Hi,

 

Ive tried updating drivers for my card with every new release since 13.9 but i then start getting compiler issues, for example:

 

[0:0:0::421]Loading "shaders/postprocess.fs.glsl"...
[0:0:0::421]...DONE
[0:0:0::421]Compile status: 0, info log:

 

Fragment shader failed to compile with the following errors:

ERROR: 0:133: error(#160) Cannot convert from: "2-component vector of vec2" to: "highp float"

ERROR: error(#273) 1 compilation errors.  No code generated

 

But worked fine in earlier versions of driver. Also going back even further i built code to use from the base of opengl insights Massive Number of Shadow-Casting Lights with Layered Rendering that with older drivers CPU use was %1-2 idle same as standard in windows, then moving to newer drivers in the same app with no change i get a constant 26-28% cpu usage, ive heard people talk about the same issue of unknown reason the cpu gets used with GPU rendering even though it shouldn't at all. Obviously something is not right.

Outcomes