8 Replies Latest reply on Mar 17, 2014 12:34 PM by gcc

    CodeXL 1.3 installation on Ubuntu 12.04 LTS

    umair039

      Hi,

       

      I am trying to install CodeXL 1.3 on my system running Ubuntu 12.04 LTS. I have Lenovo Thinkpad S540 with AMD Radeon 8670M 2GB graphics.

      To run CodeXL on my machine I updated my graphics driver to latest 13.12. Installation was OK but CodeXL just does not work. I tried to uninstall latest graphics driver and installed previous ones but I could not succeed because driver installation fails because of unexpected errors. Therefore, I have to rely on latest 13.12 which installs perfectly fine but CodeXL does not wanna run on this.

       

      Has anyone been into same problem ? Kindly help me out

      regards

        • Re: CodeXL 1.3 installation on Ubuntu 12.04 LTS
          dorono

          Can you provide more details about "does not wanna run"? Console output?

          • Re: CodeXL 1.3 installation on Ubuntu 12.04 LTS
            forester04

              Hello!

             

            I tried to run CodeXL on my Ubuntu 12.04 LTS, but it doesn't work and print error "(core dumped)".

            The most interest that CodeXL works correct with HD7970, but it stop working when I set R9 290x card into my PC.

             

            Here is backtrace of gdb bellow:

             

            maket@maket-PC:/opt/AMD/CodeXL_1.3.3487/bin$ ./CodeXL-bin

            Ошибка сегментирования (core dumped)

            maket@maket-PC:/opt/AMD/CodeXL_1.3.3487/bin$ gdb ./CodeXL-bin

            GNU gdb (Ubuntu/Linaro 7.4-2012.02-0ubuntu2) 7.4-2012.02

            Copyright (C) 2012 Free Software Foundation, Inc.

            License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

            This is free software: you are free to change and redistribute it.

            There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

            and "show warranty" for details.

            This GDB was configured as "x86_64-linux-gnu".

            For bug reporting instructions, please see:

            <http://bugs.launchpad.net/gdb-linaro/>...

            Reading symbols from /opt/AMD/CodeXL_1.3.3487/bin/CodeXL-bin...done.

             

            (gdb) backtrace

            (gdb) r

            Starting program: /opt/AMD/CodeXL_1.3.3487/bin/CodeXL-bin

            [Thread debugging using libthread_db enabled]

            Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

            [New Thread 0x7fffe31b5700 (LWP 3310)]

            [New Thread 0x7fffe1d80700 (LWP 3311)]

            [New Thread 0x7fffe157f700 (LWP 3312)]

            [New Thread 0x7fffe0d7e700 (LWP 3313)]

            [New Thread 0x7fffd97de700 (LWP 3314)]

             

             

            Program received signal SIGSEGV, Segmentation fault.

            0x00007fffc823f399 in ?? () from /usr/lib/libaticaldd.so

            (gdb) b

            Breakpoint 1 at 0x7fffc823f399

            (gdb) backtrace

            #0  0x00007fffc823f399 in ?? () from /usr/lib/libaticaldd.so

            #1  0x00007fffc8287952 in ?? () from /usr/lib/libaticaldd.so

            #2  0x00007fffc8287a9e in ?? () from /usr/lib/libaticaldd.so

            #3  0x00007fffc84f7e5e in ?? () from /usr/lib/libaticaldd.so

            #4  0x00007fffc84f8601 in ?? () from /usr/lib/libaticaldd.so

            #5  0x00007fffc84f8802 in ?? () from /usr/lib/libaticaldd.so

            #6  0x00007fffc84eefc4 in ?? () from /usr/lib/libaticaldd.so

            #7  0x00007fffc850f27d in ?? () from /usr/lib/libaticaldd.so

            #8  0x00007fffc9a6c9b8 in Backend::InitializeOpenCL (this=0x7fffc9c9e420)

                at /data/jenkins/workspace/CodeXL-Full-Linux-Release-1.3/release/CodeXL/1.3/

            CommonProjects/AMDTBackEnd/src/beBackend.cpp:2049

            #9  0x00007fffc9a6dd34 in Backend::Initialize (this=0x7fffc9c9e420)

                at /data/jenkins/workspace/CodeXL-Full-Linux-Release-1.3/release/CodeXL/1.3/

            CommonProjects/AMDTBackEnd/src/beBackend.cpp:1870

            #10 0x00007fffc9a6eb28 in Backend::Backend (this=0x7fffc9c9e420)

                at /data/jenkins/workspace/CodeXL-Full-Linux-Release-1.3/release/CodeXL/1.3/

            CommonProjects/AMDTBackEnd/src/beBackend.cpp:1824

            #11 0x00007fffc9a6ee9a in __static_initialization_and_destruction_0 (

                __initialize_p=<optimized out>, __priority=<optimized out>)

                at /data/jenkins/workspace/CodeXL-Full-Linux-Release-1.3/release/CodeXL/1.3/

            Common/Src/TSingleton/TSingleton.h:159

            #12 global constructors keyed to beBackend.cpp(void) ()

            ---Type <return> to continue, or q <return> to quit---

             

              Hope you can help me.

              Roman.

              • Re: Re: CodeXL 1.3 installation on Ubuntu 12.04 LTS
                gcc

                I have the same/similar problem.

                     Ubuntu 13.10      AMD R9 290X

                 

                george@desktop2:/opt/CodeXL_1.3.3487/bin$ ./CodeXL

                ./CodeXL: line 41: 13760 Segmentation fault (core dumped) /opt/AMD/CodeXL_1.3.3487/bin/./CodeXL-bin

                 

                logfile is attached.

                My other OpenCL stuff appears to be working ok - I can compile and run opencl code, run phoronix benchmarks etc.

                 

                I see this was first asked here in January, asked again in February. Has anyone had any success in fixing it?  Or has anyone managed to run CodeXL on linux?

                 

                Thanks,

                george