7 Replies Latest reply on Jan 23, 2014 11:39 PM by ravkum

    Unified SDK installer : not launching

    spectral

      Hi,

       

      I have download the new Unified SDK installer (Win 64)... but when I try to launch it, a first window appear (User Account Control), it is the system dialog box... byt after nothing happend !

       

      Thx

       

      Krys

        • Re: Unified SDK installer : not launching
          himanshu.gautam

          As mentioned by some user in the forum, you should have internet connection to continue installation.

          Try installing with internet. I can say only this for the information provided by you. In case if you are facing still more problem, please specify the complete details like system configuration , point out the problem properly.

            • Re: Unified SDK installer : not launching
              spectral

              Thanks,

               

              But I have an Internet connection and there is no firewall !

               

              It is under windows 8.1 64 bits. Do you need something else ?

               

              Krys

                • Re: Unified SDK installer : not launching
                  spectral

                  Hi Himanshu,

                   

                  What should I do to fix the problem ?

                   

                  Thanks

                    • Re: Unified SDK installer : not launching
                      himanshu.gautam

                      could you please send us the log and the screen shot of the error page.

                        • Re: Unified SDK installer : not launching
                          spectral

                          Hi,

                           

                          I have finally install it with the normal package but I'm not sure that the SDK is well installed !!!

                           

                          I have recompile my software... and no change was requested in the code !

                           

                          I have 2 issues :

                           

                          1) When I choose the platform it show "OpenCL 1.1 AMD-APP (831.4)". Is it normal ? (I don't have any AMD GPU on this machine, I try to run on CPU first)

                           

                          I have notice that there are several versions of OpenCL.dll:

                          1) In the AMD SDK

                          2) In the System32 folder

                          3) In the NVIDIA folder

                           

                          It seems to me that there are some conflicts between the DLLs ! I still have to try to remove the NVIDIA dlls...

                          But it seems to me that everybody should try to install the DLLs in the same folder (surely the System32 and SysWow64 folders), and even during your installation you should check if

                          there is no 1.1 version of OpenCL.DLL and remove it or change some system paths to use your DLLs and not the NVIDIA one.

                           

                          It is a situation that "can" occur on a consumer machine, right ?

                           

                          Anyway, I have delete all the OpenCL.dll that have a version 1.0, but I still got OpenCL 1.1 for AMD (from clinfo) !

                           

                          Any idea to help me go to OpenCL 1.2 ?

                           

                          2) When it compile the kernel I got the following crash, here is the stack :


                          cl::detail::getInfoHelper<cl::detail::GetInfoFunctor1<int (__cdecl*)(_cl_program * __ptr64,_cl_device_id * __ptr64,unsigned int,unsigned __int64,void * __ptr64,unsigned __int64 * __ptr64),_cl_program * __ptr64,_cl_device_id * __ptr64> >(cl::detail::GetInfoFunctor1<int (__cdecl*)(_cl_program *,_cl_device_id *,unsigned int,unsigned __int64,void *,unsigned __int64 *),_cl_program *,_cl_device_id *> f, unsigned int name, std::basic_string<char,std::char_traits<char>,std::allocator<char> > * param, long __formal) Line 1172    C++
                          cl::detail::getInfo<int (__cdecl*)(_cl_program * __ptr64,_cl_device_id * __ptr64,unsigned int,unsigned __int64,void * __ptr64,unsigned __int64 * __ptr64),_cl_program * __ptr64,_cl_device_id * __ptr64,std::basic_string<char,std::char_traits<char>,std::allocator<char> > >(int (_cl_program *, _cl_device_id *, unsigned int, unsigned __int64, void *, unsigned __int64 *) * f, _cl_program * const & arg0, _cl_device_id * const & arg1, unsigned int name, std::basic_string<char,std::char_traits<char>,std::allocator<char> > * param) Line 1539    C++
                          cl::Program::getBuildInfo<std::basic_string<char,std::char_traits<char>,std::allocator<char> > >(const cl::Device & device, unsigned int name, std::basic_string<char,std::char_traits<char>,std::allocator<char> > * param) Line 4946    C++
                          cl::Program::getBuildInfo<4483>(const cl::Device & device, int * err) Line 4955    C++
                          spectralCore::CLCompiler::CompileCLKernel(std::basic_string<char,std::char_traits<char>,std::allocator<char> > kernelSource, const char * kernelBinaryFileName, char * buildOptions) Line 46    C++

                           

                          It crash at the line : "char* value = (char*) alloca(required);", where required = 1126347 (cl.hpp : line 1165).

                  • Re: Unified SDK installer : not launching
                    ravkum

                    Hi Krys,

                     

                    Did you ever get this working?

                    Please share your machine configurations: cpu, gpu, drivers installed, etc.

                     

                    Regards,

                    Ravi