AnsweredAssumed Answered

ACML Error calling dnrm2 - Am I using the right version?

Question asked by nordwall on Nov 1, 2013
Latest reply on Nov 1, 2013 by nordwall

Hello,

 

I am doing my master thesis at The University of Linköping (Sweden). Currently Im working on creating a direction field that describes an input mesh. For that I need to solve a linear system and have chosen to use the SuiteSparse QR solver to solve my problem.

 

I have managed to build SuiteSparse and the SPQR library Im working with in Windows, which both hardly depend on the ACML library. But when I run my code (no compiling errors) it crashes when the SPQR lib makes a call to the dnrm2 function in the ACML library libacml_mp_dll.lib. Ive read this and chosen to use the fortran x64 version. I think Ive tried all of the windows installers but I still get the same error - "Unhandled exception at 0x000007FED30A0B20 (libacml_mp_dll.dll)  - Access violation reading location 0x0000000023CAFF00."

 

The call looks like this:

norm = BLAS_DNRM2 (&N, X, &one) ;

 

where N and one are integers.

 

BLAS_NDRM2 is defined as following:

#define BLAS_DNRM2    dnrm2

double BLAS_DNRM2 (BLAS_INT *n, double *X, BLAS_INT *incx) ;

 

Ive seen other definitions including underscores "_", but if I have understood things correctly it is not the version I want to use in Windows. I've compiled all my libraries in Visual Studio 2012 with the v110 compiler.

 

Any help would be appreciated, Ive been stuck on this for almost a week now. I'll happily describe the problem in more detail if needed.

 

//Douglas

Outcomes