2 Replies Latest reply on May 27, 2013 4:26 PM by amachin

    XNA 4.0 black screen with subset of ATI cards and drivers

    dasmith

      I'm a game developer currently working with XNA 4.0

      We've recently had a few cases were customers and media have been unable to play our 2 xna titles due to the program going to a black screen and staying there. The program is still running, as you can hear noises and even interact with object, but the screen is completely black. It was possible to sometimes get the screen to rerender, such as by minimizing-maximizing, but it would then go to a black screen after a few moments. This occurs in both fullscreen and windowed modes, as well as XNA's HiDef and Reach profiles. The issue seemed to occur much faster when content was being loaded/unloaded. We know that at least 2 cards and 2 drivers have this issue.

       

      Known affected cards:

       

      from DxDiag of one outside source (AMD Radeon 7850 from XFX):

           Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)

           Processor: AMD Phenom(tm) 9550 Quad-Core Processor (4 CPUs), ~2.2GHz

           Card name: AMD Radeon HD 7800 Series

           Manufacturer: Advanced Micro Devices, Inc.

           Chip type: AMD Radeon Graphics Processor (0x6819)

           DAC type: Internal DAC(400MHz)

           Device Key: Enum\PCI\VEN_1002&DEV_6819&SUBSYS_32641682&REV_00

           Display Memory: 4095 MB

           Dedicated Memory: 2031 MB

           Shared Memory: 2064 MB

           Current Mode: 1600 x 900 (32 bit) (60Hz)

           Monitor Name: HP 2009 Series Wide LCD Monitor

           Monitor Model: HP 2009

           Monitor Id: HWP2828

           Native Mode: 1600 x 900(p) (60.000Hz)

           Output Type: DVI

           Driver File Version: 8.17.0010.1172 (English)

           Driver Version: 9.12.0.0

       

      from an internal build where we were able to duplicate the issue:

      Windows 7 64-bit

      ATI 5450 HD with 13.1 drivers, 13.3 Beta, as well as the 12.1 drivers.

       

      The reason I believe it to be a driver issue is that 1) I removed 99% of the rendering functionality out of our 2 games and it still occured, and 2) When I removed the ATI drivers and let Windows 7 install it's default video drivers, the game ran fine without incident.

       

      Thank you for any help with this issue.

        • Re: XNA 4.0 black screen with subset of ATI cards and drivers
          superatron

          We've been seeing the same problem in our XNA game.  We've had about half a dozen customers complain of the exact same symptoms - screen suddenly goes black while audio and gameplay appears to continue.  Does anyone have any clues about this?  Is there some fix in XNA?  Could it be tied to refresh rates or render targets (our research revealed that others have had similar issues tied to those things)?

           

          many thanks to anyone that can help.

          • Re: XNA 4.0 black screen with subset of ATI cards and drivers
            amachin

            A user trying to play my XNA game has also reported the same exact issue: Screen going black almost immediately after running the game, but music and controls still seem to work. He is using the ATI Radeon HD 5670 with the latest driver (Catalyst Version 13.4, released 4/24/2013).

             

            Have you @dasmith or @superatron, been able to resolve this issue with your respective problem cards? Has anyone contacted AMD directly? If not, I'd be more than happy to write them a direct email. Just want to know what kind of feedback others may have already gotten. Thanks.