1 Reply Latest reply on Apr 9, 2013 4:51 AM by doctorhel

    D3DImage do not show up when configure the switable graphics to Radeon Adapter

    freedayman

      Hi AMD Tech Support and all, 

           I come across a problem with D3DImage of WPF D3D Interop Application on a dell laptop with dual graphics adapter(AMD Radeon HD 7450M and Intel HD Graphic 3000) on 64bit Windows7. When configured the application with power saving adapter using Catalyst Control Center, everything as expected, however it is configured to run with high performance adapter, D3DImage do not show up. I run the same binary code on other laptop with dual graphics adapter (intel HD Graphic 4000 and Nvidia Geforce GTX 660M), everything is ok not matter what adapter the appliction running on.  Can anyone give me any advices?

            Attachment is the source code for the issue.

        • Re: D3DImage do not show up when configure the switable graphics to Radeon Adapter
          doctorhel

          I think this question can be more general:

           

          Can someone from AMD confirm that d3d9ex+ resource sharing does NOT work when applications run on the discrete GPU on the latest model laptops with switchable graphics ? I think this really need a clarification , is it a limitation that will be permanent or is it a driver bug that we can assume will be addressed in an upcoming release.

           

          Laptop used for testing:

          Laptop HP Pavilion G4-2130TX


          Radeon HD 7670M

          Driver date: 03.11.2012

          Driver version: 8.982.10.1600

          CCC 2012.1104.523.9449