8 Replies Latest reply on Feb 27, 2013 9:49 AM by pqyptixa

    [Issue Report]: AMD Dual graphics technology

    mattyy1hp

      I have a laptop with the AMD Dual Graphics technology.

      This technology contains AMD APU (Accelerated procesor) + AMD GPU (dedicated GPU) to work together in crossfire.

      I know that this technology is designed for Windows in DirectX 10 and DirectX 11. But there are also a lot of issues with this combination.

      I don't know, how to describe some issues, so I attached a screenshots.

       

      My specs:

      CPU/APU: AMD A6-3400M with AMD Radeon HD 6520G APU

      GPU: AMD Radeon HD 6470M

      OS: Linux Mint 13 'Maya' 64bit

      Kernel: 3.6.5

      Drivers:  AMD Catalyst Linux proprietary driver 13.1

      Configuration: "amdconfig --initial" and "amdconfig --initial --adapter=all" - it's same

       

      Crossfire don't work. But Catalyst let me at least to switch between both graphics cards.

      This issues I didn't had on my previous laptop with only one AMD GPU, so, I'm assume that are caused by AMD Dual Graphics.

      I tried: Cinnamon, Cinnamon 2D, MATE, Gnome 3, Xfce, Unity (on Ubuntu) - no difference

       

      When I'm on 6520G APU:

       

      1/ Taking a screenshots on Cinnamon

      - For example: If I have Firefox minimalized in the taskbar and I do a screenshot of my desktop, I see Firefox on the screenshoot

       

      2/ AMD Catalyst don't show the dedicated GPU

      - I don't know, if this is a bug. I can post a screenshot, because I can't take screenshot on this graphics card - look at my "issue 1"

       

      3/ vSync don't work

      - There is a invisible line on the top of a screen where the vSync don't work. Look at screenshot 6520g_vsync.png.

      - of course, I have "wait for vertical sync" - "always on"

      ______________________________________________________________________________________________________

       

      When I'm on 6470M dedicated GPU:

       

      1/ vSync don't work

      - There is a invisible line on the top of a screen where the vSync don't work. Look at screenshot "6470m_vsync.png"

      - The top part is rendered slower than the bottom one.

      - Much worse than same issue on APU.

      - I have "wait for vertical sync" on "always on"

      - I can't capture it on screenshot, only on a photo, look at "vsync.jpg".

      - It's much worse in movies and games

       

      2/ AMD Catalyst shows both graphics cards

      - I don't know, if this is a bug. On APU, I don't see this GPU (look at my "issue 2" on APU) and screenshot "both_gpus_on_6470m.png"

       

      3/ AMD Vari-Bright don't work

      - Vari-bright is always set to "maximize battery life". If I change it to any other value and confirm it by "apply", it will return back to "maximize battery life"

       

      4/ Can't start TF2

      - This is not happen on 6520G APU

      - TF2 hangs on "loading ..." screen after Valve logo

      - I waited more than 30 minutes, it never starts

      - https://github.com/ValveSoftware/steam-for-linux/issues/407

       

      5/ Display settings shows APU, no GPU

      - I have activated the dedicated GPU 6470M, but in AMD catalyst, it shows AMD 6520G APU, look at screenshot "displays.png"