AnsweredAssumed Answered

Kernelanalyzer refuses to compile anything

Question asked by madsbuvi on Oct 31, 2012
Latest reply on Dec 17, 2012 by dorono

Whenever I've tried to use the kernelanalyzer for the past few days, it will refuse to compile anything, even simple test kernels, without any errors in compiler output and nothing but "Error compiling OpenCL kernel" in object code. However, it will say "OpenCL Compile Error: Can't find the IL for <any target>" if i compile a source with no __kernel functions. If i add the __kernel flag back the compiler will again stop giving any output.

 

I've tried following the steps suggested in http://devgurus.amd.com/message/1282388 which fixed a very similar problem for someone else.

However i still get the problem, and i have never used any beta drivers.

 

Adding the option "-fbin-amdil" did not help.

 

I am using

Driver Packaging Version    9.002-120928m-148276C-ATI

Catalyst Version    12.10

AMD APP SDK 2.7

AMD APP KernelAnalyzer 1.12.1288

 

I was using Catalyst Version 12.6 when the problem began, but the steps followed in the discussion i linked should have wiped all traces of this,

 

Any help would be appreciated.

Attachments

Outcomes