AnsweredAssumed Answered

Workstation freeze using fglrx 8.982.8

Question asked by MarkusIN on Oct 22, 2012
Latest reply on Oct 23, 2012 by chm

Hi,

 

the use of the OpenGL API within your software leads to a complete workstation freeze using fglrx driver version 8.982. The workstation does not accept any mouse or keyboard commands only hard reset is possible.

 

System: Linux (RHEL 6.1, Kernel: 2.6.32-279.el6.x86_64) workstation

Hardware: AMD FirePro V7900 (ATI FireGL) using driver version 8.982 (fglrx64_p_i_c-8.982.8.1-1.x86_64).

 

Last output in /var/log/messages:

Oct 20 01:30:50 SERV-10 kernel: iST: page allocation failure. order:6, mode:0xd0

Oct 20 01:30:50 SERV-10 kernel: Pid: 11000, comm: iST Tainted: P           ---------------    2.6.32-279.el6.x86_64 #1

Oct 20 01:30:50 SERV-10 kernel: Call Trace:

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff8112759f>] ? __alloc_pages_nodemask+0x77f/0x940

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff81161d62>] ? kmem_getpages+0x62/0x170

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff8116297a>] ? fallback_alloc+0x1ba/0x270

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff811623cf>] ? cache_grow+0x2cf/0x320

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff811626f9>] ? ____cache_alloc_node+0x99/0x160

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa028f9aa>] ? KCL_SetPageCache_Array+0x2a/0xf0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffff81163329>] ? __kmalloc+0x189/0x220

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa028f9aa>] ? KCL_SetPageCache_Array+0x2a/0xf0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02af495>] ? __kbd_allocate_pages+0x225/0x310 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02ad61c>] ? __alloc_memory_uswc+0xcc/0x250 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02ab6fe>] ? gal_alloc_gart_memory+0x3e/0xa0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02b5471>] ? __mc_heap_alloc_memory+0xf1/0x1f0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02b0c0e>] ? mc_heap_allocate_memory+0x5e/0xe0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa02a55e4>] ? MCIL_AllocateMemoryInDescriptor+0x74/0xe0 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa030c18e>] ? _ZN2OS10gart_AllocEP7CMMPoolmmRm9_CMM_HEAP+0xfe/0x200 [fglrx]

Oct 20 01:30:50 SERV-10 kernel: [<ffffffffa03120a9>] ? _ZN12CMMHeap_GART10expandHeapEmRmPv+0x89/0xf0Oct 22 09:19:44 SERV-10 kernel: imklog 4.6.2, log source = /proc/kmsg started.

 

We still do not know what exactly leads to this problem or how we can debug it. Any ideas?

 

Thank you

Outcomes