AnsweredAssumed Answered

Problems building openmpi 1.6 with AMD open64 compiler

Question asked by mithion on Aug 10, 2012
Latest reply on Aug 23, 2012 by santosh.zanjurne

With the new release of AMD open64 4.5.2, I wanted to recompile openmpi to support the new version. However I've been having problems building openmpi. I've tried different things. However, when I run the following configure command:

 

# ./configure --prefix=/usr/local/openmpi CC=opencc CXX=openCC F77=openf90 FC=openf90 CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64

 

Results in the following error:

 

checking Fortran 90 kind of MPI_INTERGER_KIND (selected_int_kind(9))... ./configure: line 53651: 16695 Illegal instruction     ./conftest 1>&5 2>&1

configure: error: Could not determine kind of selected_int_kind(MPI_INTEGER_KIND)

 

I've also tried omitting specifying the F77 variable in the configure line. This allows the configuration to proceed error free and I can subsequently build and install openmpi. However doing this results in an error message saying that openmpi was not built with Fortran 90 support so the command mpif90 does not work. Anybody else seeing these kinds of errors?

 

Philippe

Outcomes