AnsweredAssumed Answered

Entry point "clEnqueueMarkerWithWaitList" not found in OpenCL.dll

Question asked by reimann on Aug 9, 2012
Latest reply on Aug 9, 2012 by nou

Hello,

 

I've installed the AMD App SDK, Samples and the actual Catalyst on Vista Business 64 bit Edition (SP2).

System: AMD 3650 APU

IDE: Visual C++ Express Edition 2010

 

I've read another post on the forum about openCL.dll ("Function not found in OpenCL.dll") but it wasn't the answer for my issue.

 

The OpenCl.dll is installed. It was possible to compile several samples e.g. "Mandelbrot". If I try to build the provided sample "ImageOverlap" there are no errors shown but - if I try to execute the *.exe it fails with the message that no entry point were found. It's not the only sample. It seems that every sample which is using something like a *.bmp file crashes before the main() is reached???

I tried to debug the code but wasn't able to find the "error". The sample seems to be shut down before execution of main() can happen.

 

Any help is welcome. Feel free to ask if U need more information 'bout that issue.

 

regards

Stefan

 

Nachricht wurde geändert durch: Stefan Reimann Thanks a lot. VS C++ loads the Dll from SysWoW to run the 32bit Sample in a 64bit environment. In the folder SysWoW I found a OpenCl.dll which was from 2011. I replaced that old Dll as You'd recommanded with the 2012 OpenCl.dll that was installed in APPSDKROOT/bin/x86 and it worked. Now i'm faced with some AccessViolation but this has nothing to do with this post.

Outcomes