3 Replies Latest reply on Jul 20, 2012 11:23 AM by bragadeesh

    Help with clAmdFft

    9705glr

      Hi. I have written a code for computing several 1d ffts using the clAmdFft libraries. My code compiles and "works" but I can only get correct results for ffts of constants functions. Whenever I put a sinus or a linear function, I got a really really noisy fft (secondary waves of 30% of amplitude at least when I do the inverse fft with matlab); however I'm unable to find any error.

      Any source of help/tip would be great.

       

      thanks

        • Re: Help with clAmdFft
          bragadeesh

          Hi,

           

          In the sample code that you have attached, I see that you are computing a forward FFT with a specific input signal. Were you able to perform the same forward FFT with the same signal on MATLAB and compare the results with what the library produced? Are the results significantly different? It is normal for slight floating point differeces between two implementations of FFT. But if the differences are substantial, then there is some problem and we would have to invetsigate.

           

          It is not clear what kind of help you are looking for. Do you need help with the mathematical aspect of FFT? or do you think that the library is not producing correct results? If you are saying that the library is not producing the right numbers, could you please attach a text file with results from MATLAB and the library showning the difference. Thanks.

            • Re: Help with clAmdFft
              9705glr

              Hi.

               

              The ifft of the signal it's like 8 points of the source sinus, rest null. I was running it over a NVIDIA 580gtx; when I run it in an AMD 6450 runs correctly. What's the problem with NVIDIA?? Isn't this portable??

                • Re: Help with clAmdFft
                  bragadeesh

                  Hi,

                   

                  In theory, library should be portable to any platform that supports OpenCL. But in practice, we have seen some users reporting issues on Nvidia cards. Much of our testing is dedicated to verifying library's correctness on AMD GPU, CPU and APUs. You may have to report this problem to Nvidia and have them resolve this since AMD has no control over the underlying OpenCL runtime provided by Nividia to support their GPUs.