4 Replies Latest reply on Dec 11, 2013 2:49 AM by faroncoder

    Catalyst Control Center command line

    vosslertux

      Hello,

       

      I am a Linux user and I have a problem when I used 2 screens on Ubuntu 12.04. When I configure my display in the Catalyst Control Center I can do what I want but it is not save, when I reboot my parameters are deleted, I have the same display on my 2 screens.

       

      So Can I use the Catalyst Control Center in Command Line? I want to write a script which configure my display at the starting.

       

      Thank you for your help

        • Re: Catalyst Control Center command line

          Great question.

           

          I'll forward your question to the Catalyst QA team, but you might also try the following resources to get a faster answer:

           

           

          Cheers!

          Kristen

           

          Message was edited by: Kristen Carney

          • Re: Catalyst Control Center command line
            sirishkumar

            Hi,

             

            This is Sirish from QA team.

            We didn’t observe this issue in RHEL and SUSE during our testing in 8.98 release, we have well covered this scenario. Issue can be specific to Ubuntu 12.04.

             

            As per the issue reported, user is not able to retain the display configuration after reboot and the enabled 2 displays always goes to Clone mode after reboot. Please note that if User is initializing the configuration file (amdconfig --initial –f) after reboot, all the setting will go to the preferred values and displays will get configured in Clone.

            We can get all the commands for configuring the displays using: “amdconfig --help” command.

             

            Regards,

            Sirish

            • Re: Catalyst Control Center command line
              faroncoder

              Hello --

               

              This issue have been haunting me for remainder year since I got this CPU with AMD.  Just tonight, I finally got it working but in this step of order (important)

               

              AMD Radeon and using Ubuntu Linux OS

              ----------------------------------------------------------

               

              1. Edit your GRUB file /etc/default/grub (Ubuntu based)

              non-Ubuntu: try this command: $ find / -type f -name '*grub"' and you should find it

              old:

              GRUB_CMDLINE_LINUX=""

              fix:

              GRUB_CMDLINE_LINUX="quiet splash nomodeset"

              "quiet splash" is an Ubuntu related but for non-Ubuntu: just use "nomodeset"

              $ sudo update-grub

              $ sudo reboot

               

              2. Update your flgrx installation

              $ sudo apt-get install -y fglrx-updates

               

              3. Configure your graphic configuration with AMD Catalyst

              $ gksu amdcccle

              This line will open the AMD Catalyst as Administrator (you will be prompted for superuser password to use it and this is the only way to get this to work)

              Do your configuration as per your preference and save the setting.


              4.  Configure your X11/XOrg settings

              Open your display setting [ Launcher --> System settings --> Displays ] and configure to your preference.  This will reconfigure your system so it'd merge with the new configuration set by AMD Catalyst.

              AMD Catalyst is graphic adapter controller meanwhile System display configuration controls the X11/Xorg.  With these steps above establishes the connection of configurations between adapter and X11, which will enable the updated flgrx to run.

               

              "Ok, what was really the problem?"

              The newer version of kernel have "standardized" the video mode setting but into inside of kernel.  With that, it means kernel registers your graphic adapter first which in turn, prevented X11/Xorg being able to gain the control of this graphic.  So, in order for your system to get the full control is to "inform" kernel to not register your graphic adapter, with this command: 'nomodeset'.

               

              There were some reports that kernel version 3.7.10 and 3.8.3 doesn't do much but were solved by using 'modeset=0' (without single quotes when editing your grub).

               

              Hope this helps

              ---

              Sources:

              Ubuntu Forums

              installation - My computer boots to a black screen, what options do I have to fix it? - Ask Ubuntu

              nomodeset may no longer work >> use modeset=0 for graphical install on legacy hardware