19 Replies Latest reply on Nov 3, 2012 3:52 AM by spremi

    Fedora 17 Catalyst 12.6

    settle

      I'm running Fedora 17 (kernel.86_64 3.3.4-5.fc17) on my HP dv6z-6b00 CTO (A8-3530MX and Radeon HD 6750M).

       

      A couple months ago I was running Catalyst 12.4 without too many problems, although it lacks several features (e.g., crossfire and dynamic graphics switching) available with Windows 7.  Since then I updated to Catalyst 12.6 beta (which displayed a testing use only watermark) to the final Catalyst 12.6.  Strangely, now I have an unsupported hardware watermark that I never had with Catalyst 12.4.  Things with Catalyst 12.6 seem to work more or less similar to Catalyst 12.4, but the watermark is annoying and indicates to me a step backwards in support.  What happened?

       

      I'm also interested in other customers' experiences.  What other things seem to have improved/broken or not changed that you were hoping would?

        • Re: Fedora 17 Catalyst 12.6

          Sean,

          Sorry to hear about the issues since you switched to Catalyst 12.6. There have been a few other recent posts about Catalyst 12.6 in the Developer Forums, but I don't recall any other reports about the watermark.

           

          I'll forward your comments about the watermark to the Catalyst QA team, but here are 2 other Catalyst resources for you to get more information & to report issues. You should definitely use the 2nd link to report the watermark issue as well as anything else that you've found.

           

           

           

          Cheers!

          Kristen

           

          Message was edited by: Kristen Carney

          • Re: Fedora 17 Catalyst 12.6
            sirishkumar

            Hi,

             

            This is Sirish from QA team. We did a quick verification on our current distro in coverage:

             

            We verified the issue with appropriate configuration (Llano 9641 + Whistler Pro PX A+A + Cat 12.6 + SUSE 12.1 32bit), but issue is not reproducible. Issue can be specific to Fedora 17.

             

            Regards,

            Sirish

              • Re: Fedora 17 Catalyst 12.6
                settle

                Hello Sirish,

                 

                Thank you for your follow-up.  Maybe it's a problem with Fedora, maybe 32 bit vs. 64 bit, or a kernel version.

                 

                However, I'm having an even bigger problem with the 12.6 driver under Windows 7 64-bit.  Under Fedora 17 64-bit I get an unsupported watermark, but otherwise the driver seems to work, but under Windows 7 the Catalyst Control Center doesn't even recognize either of my notebook's graphics cards, but it worked as expected with the 12.4 driver.  Could you test that configuration as well?  Thanks!

              • Re: Fedora 17 Catalyst 12.6
                yurtesen

                settle wrote:

                 

                I'm also interested in other customers' experiences.  What other things seem to have improved/broken or not changed that you were hoping would?

                Fedora is broken as always, whats new

                 

                I attached a screenshot from my Fedora 17 64bit installation. I also see the "Unsupported hardware" mark on the right lower corner, but for some reason it did not make it to the screenshot. I have E-450 APU with Radeon 6320... I installed the driver from rpmforge if I am not mistaken just last week...  I did not report this, because it is highly possible that it will stop functioning altogether with next fedora updates anyway I will boot into Ubuntu and see what it says and put a screenshot from there too...

                  • Re: Fedora 17 Catalyst 12.6
                    yurtesen

                    Ubuntu does not seem to have the 12.6 yet in their additional drivers database.(I am not going to bother with manual install..) Anyway, there is no watermark with this version... Next windows....

                      • Re: Fedora 17 Catalyst 12.6
                        yurtesen

                        Well, I clearly remember installing 12.7 beta to windows, but it shows 12.3 (strange?)... otherwise appears to work more or less fine... I am not able to test crossfire obviously, but the only problem I had with earlier drivers in windows was the PowerPlay was not functioning properly (it was setting full speed at all times) and with 12.7 it more or less functions as expected (it still sets full speed even at battery save mode if youtube videos are watched for example...strange...)

                          • Re: Fedora 17 Catalyst 12.6
                            sirishkumar

                            Yes, Fedora is not officially supported, although driver may still work. In our understanding, the main problem in this thread is about “Unsupported watermark” with Catalyst 12.6 driver. We did receive similar reports recently, and after some investigation, we found that following devices are not supported by Catalyst 12.6.

                            ·         All mobile APUs because of an Windows specific EPR#354934

                            ·         Some rebranded ASICs (NI Turks, NI Caicos and EG Cedar).

                             

                            This could be the reason. Hope this helps.

                      • Re: Fedora 17 Catalyst 12.6
                        highking

                        Same here with both Mandriva 2011 and OpenSuse 12.1.

                        This is on a MSI Wind that I just bought last week... unsupported already? Shame on you AMD!

                         

                        The card in this  box is a AMD Radeon HD 6320.

                          • Re: Fedora 17 Catalyst 12.6
                            highking

                            Hi, using Google some more I found a workaround to remove the watermark!

                            I downloaded 12.4 and extracted the file with the "--extract" switch. Then I replaced /etc/ati/control and /etc/ati/signature with the ones in the 12.4 package. Rebooted and the watermark is gone! :-)

                             

                            Everything still seems to work fine, but it still would be nice if AMD could fix this in the next release...

                              • Re: Fedora 17 Catalyst 12.6
                                settle

                                The original post was more about the regression from Catalyst 12.4 to 12.6 on both Linux and Windows (which just doesn't work at all) than just removing an annoying watermark because removing the watermark doesn't necessarily revert the level of support back to that provided by 12.4.

                                 

                                Also, I did a quick search on "Windows specific EPR#354934", but I couldn't find anything except a link back to this forum post.  Please give us more detail about this issue and how we can track its progress.

                                  • Re: Fedora 17 Catalyst 12.6
                                    highking

                                    A quote from the original post:

                                    Strangely, now I have an unsupported hardware watermark that I never had with Catalyst 12.4.  Things with Catalyst 12.6 seem to work more or less similar to Catalyst 12.4, but the watermark is annoying and indicates to me a step backwards in support.  What happened?

                                     

                                    How in your perception is this not about the watermark?

                                      • Re: Fedora 17 Catalyst 12.6
                                        settle

                                        The most important part of the original post is that the watermark indicates a regression in support and I want to know what happened.  Although things "seem to" work, I didn't test every functionality (I don't get paid to troubleshoot for AMD, I'm a paying customer).  Removing the watermark doesn't vet that nothing else was broken, and since support in Windows 7 was completely dropped in 12.6 for the listed AMD devices, it concerns me that something significant may be broken and just waiting to jump out and bite me if I continued to use it (despite not even being a beta driver).  I have since reverted back to 12.4 and am waiting to hear that full support has been reinstated.

                                • Re: Fedora 17 Catalyst 12.6
                                  spremi

                                  just upgraded Fedora 17 and am noticing the AMD Unsupported hadrware watermark for my ATI Radeon HD 5700 card as well.

                                  Don't have yum update log, but this should help:

                                  $ rpm -qa | grep kmod

                                  kmod-catalyst-12.6-1.fc16.x86_64

                                  kmod-catalyst-3.4.9-2.fc16.x86_64-12.4-4.fc16.8.x86_64

                                  libmikmod-3.2.0-12.beta2.fc15.x86_64

                                  kmod-catalyst-3.6.2-1.fc16.x86_64-12.6-1.fc16.x86_64

                                  kmod-catalyst-3.4.11-1.fc16.x86_64-12.4-4.fc16.9.x86_64

                                  $ lspci | grep -i radeon

                                  03:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]

                                  03:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]

                                  $ su -

                                  Password:

                                  # cd /var/log

                                  # grep 5700 *

                                  Xorg.0.log:[    21.999] (--) fglrx(0): Chipset: "ATI Radeon HD 5700 Series" (Chipset = 0x68b8)

                                  Xorg.0.log:[    22.433] (II) fglrx(0): Adapter ATI Radeon HD 5700 Series has 5 configurable heads and 1 displays connected.

                                  Xorg.0.log.old:[    21.017] (--) fglrx(0): Chipset: "ATI Radeon HD 5700 Series" (Chipset = 0x68b8)

                                  Xorg.0.log.old:[    21.512] (II) fglrx(0): Adapter ATI Radeon HD 5700 Series has 5 configurable heads and 1 displays connected.

                                  Xorg.9.log:     ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),

                                  Xorg.9.log:     ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,

                                  Xorg.9.log:     ATI Mobility Radeon HD 5800 Series, ATI Radeon HD 5700 Series,

                                  Xorg.9.log:     ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,

                                  Xorg.9.log:     ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,

                                  Xorg.9.log:[    15.727] (--) RADEON(0): Chipset: "ATI Radeon HD 5700 Series" (ChipID = 0x68b8)

                                  # grep Operating Xorg.0.log

                                  [    21.695] Build Operating System: x86-01 2.6.32-220.4.1.el6.x86_64

                                  [    21.695] Current Operating System: Linux xxxxxxxxxxx.hom 3.6.2-1.fc16.x86_64 #1 SMP Wed Oct 17 05:30:01 UTC 2012 x86_64

                                  #