4 Replies Latest reply on Mar 21, 2012 1:12 PM by smatovic

    AMD A8 3870K Black Edition and AMD Radeon HD 7750 in Linux

    settle

      I recently bought for my lab four systems each containing an AMD A8 3870K Black Edition and and AMD Radeon HD 7750.  My lab only uses linux and we wish to uses these systems to test algorithms using OpenCL.  However, after setting the discrete graphics card as the primary display in the BIOS, installing the AMD Proprietary Catalyst 12.3 linux drivers, and setting the xorg.conf, the screen is corrupted and in the bottom right corner there is a watermark saying "Unsupported Hardware."  I tried setting the integrated graphics card as the primary display in the BIOS and adjusted the xorg.conf file accordingly, but then the screen just goes blank when the login screen should popup.  I tracked the problem to the 7750 graphics card as the system worked perfectly when I removed it.  Since I'm also having trouble with a pair of AMD Radeon HD 7950 in linux (see separate post), I'm starting to wonder if all 7xxx graphics cards are not yet supported in linux.  If that's true, I've got five brand new systems with eight 7xxx graphics cards (we bought some for dual configurations) that are just sitting around collecting dust.  Is there any solution or hotfix to what appears to be a driver problem in CentOS 6.2, Fedora 16, and OpenSUSE 12.1?