8 Replies Latest reply on May 1, 2012 4:14 PM by Skysnake

    How to draw smooth lines with ATI-Cards in OpenGL by using GLUT

    andrer

      Hello,

       

      I'm creating an interactive 3D-Molecule-kit for chemistry teaching and I experienced some problems with ati-cards.

       

      When I try to draw smooth lines this way:

       

      glutInitDisplayMode(GLUT_DOUBLE | GLUT_RGB | GLUT_DEPTH);

      ...

      gluLookAt(mycam.pos[0], mycam.pos[1], mycam.pos[2], mycam.focus[0], mycam.focus[1], mycam.focus[2], 0,1,0);  //3D-projection

      ...

      glShadeModel(GL_SMOOTH);

      glEnable(GL_BLEND);

      glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);

      glEnable(GL_LINE_SMOOTH);

       

      I get usual (non-antialiased) lines with ati cards. When I execute my code on nvidia cards then it works perfectly.

      The same behavior appears, when I try to use the accumulation buffer to do full-scene antialiasing or motion blur.

      With nvidia cards -> it works

      With ati cards -> no effect

       

      Is there any way to enable antialiasing (FSAA) in OpenGL by using GLUT and ATI-Cards?

      Or is there a command to force ati-cards to FSAA? May be like the option of Antialiasing in ATI Tray Tools?

       

      Thanks for any help

      André