2 Replies Latest reply on Jan 30, 2012 8:42 AM by spacenoid

    Segmentation Fault when running APP SDK Samples. Debian Wheezy

    spacenoid

      I am receiving a segmentation fault when I try to run the samples provided with the APP SDK.

       

      I ran HelloCL with gdb and found this error:

       

      1538        cl_int err = ::clGetPlatformIDs(0, NULL, &n);

      (gdb) step

      st

      Program received signal SIGSEGV, Segmentation fault.

      0x00007ffff7555103 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6

       

      brian@newton:~/etc/OpenCL/vendors$ fglrxinfo

      display: 0  screen: 0

      OpenGL vendor string: Advanced Micro Devices, Inc.

      OpenGL renderer string: AMD Radeon HD 6900 Series

      OpenGL version string: 4.2.11399 Compatibility Profile Context

       

      I have tried running these samples after installing from the source .tar provided on the AMD site and also by installing amd-libopencl1 from the Debian non-free package archive. Both have provided the same results.

       

      Please help!