1 Reply Latest reply on Jan 25, 2012 3:10 AM by santosh.zanjurne

    Binutil version

    florian.uhlig
      Is the new binutil version needed for open64-4.5.1 only a compile or also a runtime requirement

      Hi,

      to compile open64 with "bulldozer" support on Debian Squeeze I had to backport the binutils from Wheezy to Squeeze. This was done only for a dedicated build server. For our compute cluster I wouldn't like to install the backport of the binutils. For the cluster I would like to run with the default binutils.

      Reading the installation instructions for the compiler it is not clear to me if the new binutils version are only a compile time requirement or also a requirement at runtime.

       

      > To take advantage of the new AMD Opteron Family 15h processor("Bulldozer" > core) instructions, you will need a version of Binutils that is 

      > 2.20.0.20100122-0.7.9 or above to support AVX,XOP,FMA4 etc. We used

      > 64-bit SUSE Linux Enterprise Server 11 with SP1 to build the compiler for

      > AMD Opteron Family 15h processor ("Bulldozer" core). Besides, we used

      > 64-bit SUSE Linux Enterprise Server 10 with SP2 to build the compiler for

      > systems that does not comply to the above mentioned Binutils version.

      > For best performance on AMD Opteron Family 15h processor("Bulldozer"core)

      > it is recommended to use binutils-2.21 or above.

      Hope you can help me.

       

      With best regards

      Florian

       


       

        • Re: Binutil version
          santosh.zanjurne

          Hello Florian,

           

          You will need the latest version of binutils because they have the necessary requirement to use the newest Bulldozer based cpus.  Use binutils 2.21 or later for the best performance.  I havent understood why you needed to back port them though!  You should be able to use the Open64 compiler binaries on Wheezy and let me know if you have any issues there.

           

          Regards,

           

          Santosh