4 Replies Latest reply on Jun 4, 2013 7:33 AM by petr.machacek

    GDebugger 6.1 - ENV Path

      Set ENV Path

      In VS2010 I set the environment variables under the project settings Debugging page. 

      When I start my opengl program with gdebugger via the gedebugger menu  ("Start OpenGL Degugging"), it doesn't seem that the variables get merged into the current session. 

      The old version of gdebugger (5.8) had the ability to set env. variables for a debugging session, is there a solution to this for the 6.1 version of gdebugger ?

      Thanks for the help.

        • GDebugger 6.1 - ENV Path

          Other than the build options environment variable, these variables should be recognized (the functionality worked in v6.0).  What is the environment variable you are trying to set?

            • GDebugger 6.1 - ENV Path

              I think i got it.. I was setting the PATH variable based on some macros from the project properties page. 

              Setting it without the macro seemed to work..

              Thanks for the reply.

                • GDebugger 6.1 - ENV Path


                  May I ask how you got this working?

                  I have data in my Project Properties -> Configuration -> Debugging -> Environment that looks like this:


                  And the application exits with code (0xc0000135) when it tries to start up with gDEBugger v6.1.262.0 in VS 2010 Professional. Debugging the application as normal is fine.

                  Furthermore, if I open an instance of cmd.exe, copy and paste the environment command listed above into the command prompt, then start devenv.exe, I can run gDEBugger just fine.

                  I'm thinking I will switch back to the standalone v5.8 until this is fixed unless there is a good workaround I haven't found yet.


                    • Re: GDebugger 6.1 - ENV Path

                      Hello baker,

                      I'd like to ask whether you made it work..

                      Actually I have the same problem. I'm using gDEBugger v6.2.865.0 in VS 2010 Professional and launching gDEBugger (64bit version) allways exits with code (0xc0000135).

                      Which paths are you setting in cmd.exe? Paths to executables to you program being debugged?

                      Thanks in advance.