1 Reply Latest reply on Jan 30, 2012 4:29 AM by kalyanpk

    CodeAnalyst gives "Error starting profile, please try disabling watchdog timer.." (and the latter doesn't work)

    milos
      asks to try disabling watchdog timer, which in turn doesn't seem possible

      Hi,

      I'm having a problem with running an app in CodeAnalyst, on RHEL 5.  When I configure a run, and press the "Play" button in CodeAnalyst, a window with the following error pops up:

      "Error starting profile (window titlebar): Please try disabling the watchdog timer by running

      opcontrol --deinit

      echo 0 > /proc/sys/kernel/nmi_watchdog

      and try running the profile again. (NOTE: root permission required)"

       

      This is my setup:

      1. I am running RHEL 5.7:

       

      [milos@precursor4 ~]$ cat /etc/redhat-release 

      Red Hat Enterprise Linux Server release 5.7 (Tikanga)

      2. I downloaded the RPMs for RHEL5U6 for CodeAnalyst and for the Kernel Modules from the AMD website:

       

      wget http://download2-developer.amd.com/amd/CodeAnalyst/CodeAnalyst-3_1_4_64-RedHatEnterpriseServer5U664bit-Public.bin.rpm

      wget http://download2-developer.amd.com/amd/CodeAnalyst/CodeAnalyst-KernelModule-3_1_4_64-RedHatEnterpriseServer5U664bit-Public.bin.rpm

      3. I installed both modules as a system user with sudo access using rpm -iv rpmname (first CodeAnalyst, then the Kernel package)
      4. I set up the path as instructed, checked that the CodeAnalyst libraries are listed in the ld.so.conf file, and used camanager to add myself as a code analyst user (that seemed to run fine.
      5. Then I ran CodeAnalyst from my account without using sudo and it loaded.  When I set up a configuration and tried to run it, the error above came up.
      6. I tried to do as instructed, and was told I couldn't do this ("permission denied") whether I used sudo or not to try to follow the instructions.
      Could anyone shed light on 1) why the error came up, and 2) why I'm not able to follow its instructions? (or even whether I should need to)?
      Many thanks for your help in advance.
      ====
      This note added to this post:  I just figured out that following the instructions the code gives you above does work (echo 0 > nmi_watchdog), but only if you actually log in as root (doesn't work to run this command using sudo).  Furthermore, I have to run this command *each* time I want to run a profile (hit the play button in CA) -- even if I haven't quit and restarted CodeAnalyst in the meantime.  Therefore, although I got it to work, it doesn't appear this is the right way to run CodeAnalyst, so any help is still gratefully appreciated.
      ====
      Milos