3 Replies Latest reply on Jan 4, 2012 1:31 PM by chipf

    Install ACML

    mutica34

      Hi! I have downloaded the acml-4-4-0-gfortran-32bit.tgz but when I decompress it and run the install-acml-4-4-0-gfortran-32bit.sh as it is written in the README, after I enter the "accept" and then the installation path(and then hit enter) the script exits.
      Is this normal?
      I used armadillo to check if ACML is installed and it seems it isn't.

      I use Ubuntu natty 32 bit.

       

        • Install ACML
          chipf

          The default installation path is in /opt.  If you don't have permissions to create a directory there, it would fail.

          If that's what is happening, either run the install with superuser priveleges, create an /opt/acml4.4.0 directory such that your user account owns it or has necessary priveleges,  or override the installation path to a directory for which you have priveleges.

          If it's something else, we'll have to look into it.

          Question:  Why is anybody still using 32-bit linux?

            • Install ACML
              mutica34

               

              I think it worked. I think ACML was installed and it's detected by Armadillo, because I want to use ACML with Armadillo, but I still have a problem. Initially I installed BLAS, Lapack, and ATLAS but the matrix multiplication didn't work, it gave me this errors:

               

               

              /usr/local/include/armadillo_bits/blas_wrapper.hpp|79|undefined reference to `wrapper_dgemv_'|

              /usr/local/include/armadillo_bits/blas_wrapper.hpp|114|undefined reference to `wrapper_dgemm_'|

               

              And now after I installed ACML I have the same problem.
              This is my C++ code:
              #include <iostream>
              #include "armadillo"
              using namespace arma;
              using namespace std;
              int main()
                {
               mat A = "1 2;3 4;5 6";
               mat B  = "2 4 8;2 4 8";
               mat C= A*B;
                cout<<C<<"\n";
                return 0;


                • Install ACML
                  chipf

                  These errors appear to originate with the armadillo source, these labels are not found in ACML.  My guess is you have some sort of configuration issue while trying to use ACML.  You should include the build command you used in addition to the code, along with any changes made to configuration files.

                  We haven't tried building the armadillo project, but the web page does claim support for ACML.

                  I suggest posting a question to the armadillo maintainer, they may be familiar with this error.