antzrhere

CPU compilation broken (?)

Discussion created by antzrhere on Nov 14, 2011
Latest reply on Nov 16, 2011 by antzrhere
"Internal Error: as failed"

I'm using SDK 2.5, Catalyst 11.10, Windows 7 64bit.

I've got my program which has been working fine up until now (apart from CPU not properly executing kernel when manipulating GL shared texture object, but that was another *lesser* problem) - on the GPU everything works 100% fine.

I've upgraded to Catalyst 11.10 and now when I use the CPU as a device type the program will not build! When I call clBuildProgram() I get the following message from the compiler : "Internal Error:  as failed".

I tried stripping down my kernel code (in case it was this), but it turns out it does this whatever code I use - even just a dummy kernel with no code. I also removed GL context creation thinking it was this, but no difference.

Basically, for me atleast - OpenCL for the CPU is completely broken! Just to re-itterate, using Catalyst 11.9 it worked fine. It also compiles and runs 100% perfect on the GPU as it always has. And aside from basic clCreateContext, clBuidProgram etc. there is no code to post...

Anyone else having this?

Outcomes