2 Replies Latest reply on Oct 30, 2011 5:33 PM by rreis

    compiling open64 with gcc 4.6

    rreis

      Hi all

      Is this possible or only with gcc 4.2 and bellow? I'm getting this error

       

      checking for gcc... gcc -m32
      checking whether the C compiler (gcc -m32  ) works... no
      configure: error: installation or configuration problem: C compiler cannot create executables.
      configure: error: /bin/bash '/home/rreis/tmp/src/open64/open64-4.2.4-src/osprey/cygnus/configure.gnu' failed for osprey/cygnus

        • compiling open64 with gcc 4.6
          mvermeulen

           

          Originally posted by: rreis

           

          Is this possible or only with gcc 4.2 and bellow? I'm getting this error

           

           

          No.  Builds with compilers newer than 4.2 as well.  Read the section on "Compiling" in the HOW-TO-INSTALL-OPEN64 document in the main directory.  The symptoms you describe are similar to what you would see if you didn't have the *-multilib (or *.686) packages installed on your system.  There are some other tips and prerequisites you'll also want to get following instructions above.

          Once you do that, with 4.6 you could run into an issue found in "g++: error: unrecognized option 'CG:all_sched=0'" string also in this forum, and read responses on that string.