2 Replies Latest reply on Oct 11, 2011 6:13 PM by DimaNovikov

    ATI Catalyst driver since 11.7 version can't work with hybrid GPU?

    DimaNovikov
      At least in my desktop computer it doesn't. Why newer drivers are worse than old one?

      <!-- @page { size: 21cm 29.7cm; margin: 2cm } P { margin-bottom: 0.21cm } -->

      I've got Radeon 5770 and 6570 in my desktop and ati-stream-sdk-v2.3-lnx32 on my OpenSUSE 11.3.

      When I install ATI Catalyst driver with a version 11.7 or higher, OpenCL doesn't see my Radeon 5770 at all. I mean CLinfo sample tells me that there is only 2 ATI Stream devices in my comp (including AMD CPU).

      Most interesting that driver 11.6 can see with all the 3 devices (2 GPU + 1 CPU) and works fine with all this hardware.

       

      What happened to drivers since 11.7 version? Why hybrid GPU are not supported any more?



        • ATI Catalyst driver since 11.7 version can't work with hybrid GPU?
          genaganna

           

          Originally posted by: DimaNovikov

          I've got Radeon 5770 and 6570 in my desktop and ati-stream-sdk-v2.3-lnx32 on my OpenSUSE 11.3.

          When I install ATI Catalyst driver with a version 11.7 or higher, OpenCL doesn't see my Radeon 5770 at all. I mean CLinfo sample tells me that there is only 2 ATI Stream devices in my comp (including AMD CPU).

          Most interesting that driver 11.6 can see with all the 3 devices (2 GPU + 1 CPU) and works fine with all this hardware.

          What happened to drivers since 11.7 version? Why hybrid GPU are not supported any more?

          Please use SDK2.5.

          To access multiple GPUs under Linux, ensure the DISPLAY environment variable is set to :0 instead of :0.0. Alternatively, set the COMPUTE environment variable to :0. If COMPUTE is set, the OpenCL SDK uses the this variable, rather than DISPLAY, to determine the available GPU devices.

            • ATI Catalyst driver since 11.7 version can't work with hybrid GPU?
              DimaNovikov

              <!-- @page { size: 21cm 29.7cm; margin: 2cm } P { margin-bottom: 0.21cm } -->

              Thanks for your answer!

              Unfortunately when I set one of these environment variables as you said, my AMD-APP-SDK-v2.5 can see just one device: CPU. That's all.

               

              ./CLInfo

               

              Number of platforms: 1

              Platform Profile: FULL_PROFILE

              Platform Version: OpenCL 1.1 AMD-APP-SDK-v2.5 (684.213)

              Platform Name: AMD Accelerated Parallel Processing

              Platform Vendor: Advanced Micro Devices, Inc.

              Platform Extensions: cl_khr_icd cl_amd_event_callback cl_amd_offline_devices

               

               

              Platform Name: AMD Accelerated Parallel Processing

              Number of devices: 1

              Device Type: CL_DEVICE_TYPE_CPU

              .........

              //================================

              So I have to roll back to the 11.6 version of driver. It works fine.