1 Reply Latest reply on Aug 22, 2011 12:57 PM by genaganna

    OpenCL 1.0 on GPU but 1.1 on CPU ?

    jasno

      Hi,

          I am using a machine which has a firestream 9270 GPU and an intel cpu. When I query the device I get the following info for the two devices

      ---------------------------------
       Device ATI RV770
       ---------------------------------
        CL_DEVICE_NAME:             ATI RV770
        CL_DEVICE_VENDOR:             Advanced Micro Devices, Inc.
        CL_DRIVER_VERSION:             CAL 1.4.1016
        CL_DEVICE_VERSION:             OpenCL 1.0 AMD-APP-SDK-v2.5 (684.213)
        CL_DEVICE_TYPE:            CL_DEVICE_TYPE_GPU
       
       ---------------------------------
       Device Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz
       ---------------------------------
        CL_DEVICE_NAME:             Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz
        CL_DEVICE_VENDOR:             GenuineIntel
        CL_DRIVER_VERSION:             2.0
        CL_DEVICE_VERSION:             OpenCL 1.1 AMD-APP-SDK-v2.5 (684.213)
        CL_DEVICE_OPENCL_C_VERSION:         OpenCL C 1.1
        CL_DEVICE_TYPE:            CL_DEVICE_TYPE_CPU

       

      The GPU says driver version is OpenCL 1.0 but the CPU driver version says OpenCL 1.1. They are both using the same SDK,is this correct ?

       

      --

      jason

        • OpenCL 1.0 on GPU but 1.1 on CPU ?
          genaganna

           

          Originally posted by: jasno Hi,

           

              I am using a machine which has a firestream 9270 GPU and an intel cpu. When I query the device I get the following info for the two devices

           

          ---------------------------------  Device ATI RV770  ---------------------------------   CL_DEVICE_NAME:             ATI RV770   CL_DEVICE_VENDOR:             Advanced Micro Devices, Inc.   CL_DRIVER_VERSION:             CAL 1.4.1016   CL_DEVICE_VERSION:             OpenCL 1.0 AMD-APP-SDK-v2.5 (684.213)   CL_DEVICE_TYPE:            CL_DEVICE_TYPE_GPU    ---------------------------------  Device Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz  ---------------------------------   CL_DEVICE_NAME:             Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz   CL_DEVICE_VENDOR:             GenuineIntel   CL_DRIVER_VERSION:             2.0   CL_DEVICE_VERSION:             OpenCL 1.1 AMD-APP-SDK-v2.5 (684.213)   CL_DEVICE_OPENCL_C_VERSION:         OpenCL C 1.1   CL_DEVICE_TYPE:            CL_DEVICE_TYPE_CPU

           

           

           

          The GPU says driver version is OpenCL 1.0 but the CPU driver version says OpenCL 1.1. They are both using the same SDK,is this correct ?

           

          Yes, All RV7XX suppot only OpenCL 1.0 spec.