6 Replies Latest reply on Feb 26, 2012 2:57 PM by yurtesen

    Graphics Clock and Open CL speed!

    Atmapuri

      Hi!

      When I run my OpenCL kernel and monitor the fan and GPU clock in the Catalyst Control center, the fan runs at low speeds and GPU clock is shown to be 400Hz out of 850MHz max. Memory at 800 instead of 1200Mhz. (ATI HD 5770).

      What does it take to trigger the switch to higher clock? Does the kernel run at full speed of the GPU or not?


      Thanks!
      Atmapuri

       

        • Graphics Clock and Open CL speed!
          himanshu.gautam

          Atmapuri,

          I don't think it is recommended to modulate the FAN speed while kernel is running. And I also feel AMD makes its GPUs intelligent enough that they don't burn out while performing at their maximum speed when not enough cooling is present.

            • Graphics Clock and Open CL speed!
              Atmapuri

              I was not adjusting fan speed. It was all default settings. The question was about the GPU clock. By default the GPU clock runs at 400Mhz and it has capacity to run 850Mhz. The fan speed is only an indicator of the heat generated which in turn is a function of the clock.

              It turned out that pressing "reset to defaults" on the ATI driver overclock page caused the clock to rise for OpenCL jobs as well. (even though there were no changes made).

                • Graphics Clock and Open CL speed!
                  Meteorhead

                  Try looking in PowerPlay option (if there is any), or in 3D settings, to set priority to "performance" instead of "energy save" and stuff like that.

                  I experience some similar problem with my laptop, that if I start the machine from battery, and plug it in later, CCC fails to realize from time to time that it could forget about energy save mode and go for performance. Only a reboot solves the issue.

                    • Graphics Clock and Open CL speed!
                      Jawed

                      The indicators in Catalyst Control Center have very slow response. You should execute a series of kernels (e.g. the same kernel launched multiple times) that run without interruption, for a few seconds, to observe consistent data in CCC.

                        • Graphics Clock and Open CL speed!
                          Meteorhead

                          Apart from what Jawed mentioned, I would like to take this opportunity to point out the similar issue I mentioned. It would be nice if CCC (or the driver, I do not know how they are structured) would realize if I plug in my laptop or switch to battery. Most of the times it stays at lower clockrates. Also it can happen that one puts the machine to sleep on battery, and wakes it up already plugged in. Not to mention that overclock fails to engage even more often in such situations.

                          I do not know how CCC and the drivers are structured, but developers could look into a bit deeper into the event handler that drives them, because it seems there are many scenarios it fails to follow.

                          Win7 x64, Mobility 5870, Catalyst XX.YY (all of them)

                  • Re: Graphics Clock and Open CL speed!
                    yurtesen

                    I seem to have the same problem on Linux. Could you ever solve it?