1 Reply Latest reply on Feb 21, 2011 4:12 PM by abstractius

    HD 5650m support in Ubuntu 10.10 x64 and newer

    abstractius

      I am posting here primarily because I couldn't see any other mechanism for Catalyst feedback to AMD. I am assuming I need X in order to use OpenCL, although as discussed 6 months ago modprobe should enable it, in principle.

      I have tried most combinations of the latest Ubuntu distributions at 64 bits, including the 11.04 alphas with my Acer 5943G. Catalyst 11.2, which creates .deb packages successfully, segfaults after informing me that my AMD product is compatible, loading modules etc.  Catalyst 10.12, the "tested" one, I installed directly, no packages,I was informed of installing driver 8.801 on X 7.6 x64, informed me of DKMS problems and, on execution, segfaults again. My only guess at this stage is that the driver would be working with some older kernel or differently configured kernel, but I need clues to find out which.

      It is annoying AMD does not have a more proper channel to collect these errors, and segmentation faults are so much 80's, is it too much to ask for programs to fail a bit more gracefully in 2011! The emergency desktop in which I am writing tried to execute the f_gears program too, and reported another seg_fault, would the architecture slow down if it had some nice error messages? Now, I understand segfaulting is good news and the core may be hiding some clues, but will there be some engineering interest? At first  thought there was something wrong with the xorg.conf, but looking around I see that aticonfig really does produce such minimalist files, without entries for resolution and bitdepths etc, looks like those are thing of the past?

      Thanks,

      AT

        • HD 5650m support in Ubuntu 10.10 x64 and newer
          abstractius

          Ok, I installed on my machine the 32bit version of everything and it works "out of the box", so the problem is AMD's support of the 64bit version. Like I said, no combination of kernel, Ubuntu version and Catalyst has worked for me yet on 64 bit, and on Windows x64 things started working properly only with the latest release. If AMD supports 32 bit better I think they should state it, we want to use 64bit but we don't want to waste our life on it!