4 Replies Latest reply on Feb 22, 2011 4:22 AM by Raistmer

    HD6970 and app crashes

    Raistmer
      driver again?

      When running 2 instances at once app experiences crash.
      Here is call stack dump, looks like it points to AMD driver/runtime...
      Driver is Catalyst 11.2

      - Callstack -
      ChildEBP RetAddr Args to Child
      04e2f6f4 691384b9 00000094 00000001 04e2f724 042b8e68 aticaldd!calddiGetExport+0x0
      04e2f71c 69137437 00000005 00000002 03786000 06c64570 aticaldd!calddiGetExport+0x0
      04e2f7d0 00000000 00000000 00000000 00000000 00000000 aticaldd!calddiGetExport+0x0

      *** Dump of thread ID 2720 (state: Initialized): ***

      - Information -
      Status: Base Priority: Normal, Priority: Normal, , Kernel Time: 0.000000, User Time: 0.000000, Wait Time: 0.000000

      - Registers -
      eax=00000000 ebx=00000000 ecx=00000000 edx=00000000 esi=000000bc edi=00000000
      eip=77a9f861 esp=0018f618 ebp=0018f684
      cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000202

      - Callstack -
      ChildEBP RetAddr Args to Child
      0018f684 76f61184 000000bc ffffffff 00000000 030ad628 ntdll!ZwWaitForSingleObject+0x0
      0018f69c 76f61138 000000bc ffffffff 00000000 030ad628 kernel32!WaitForSingleObjectEx+0x0
      0018f6b0 023c134f 000000bc ffffffff 03039654 03039654 kernel32!WaitForSingleObject+0x0
      0018f6c4 023c11f7 03039654 03039648 030b1778 00000001 atiocl!clGetSamplerInfo+0x0
      0018f6e0 023bb82f 00000000 03039648 03039654 0018f748 atiocl!clGetSamplerInfo+0x0
      0018f6fc 0237ecca 0056a154 0056a228 0018f934 00002000 atiocl!clGetSamplerInfo+0x0
      00000000 00000000 00000000 00000000 00000000 00000000 atiocl!clEnqueueReadBuffer+0x0

      *** Dump of thread ID 304 (state: Initialized): ***

      - Information -
      Status: Base Priority: Normal, Priority: Normal, , Kernel Time: 0.000000, User Time: 0.000000, Wait Time: 0.000000

      - Registers -
      eax=00000000 ebx=00000000 ecx=00000000 edx=00000000 esi=0236ff48 edi=00000000
      eip=77a9fd21 esp=0236ff04 ebp=0236ff6c
      cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000202

      - Callstack -
      ChildEBP RetAddr Args to Child
      0236ff6c 76763520 00000064 00000000 0236ff94 00454ffb ntdll!NtDelayExecution+0x0
      0236ff7c 00454ffb 00000064 00000000 76f63677 00000000 KERNELBASE!Sleep+0x0
      0236ff94 77ab9f02 00000000 7574dc94 00000000 00000000 ap_5.06_win_x86_SSE2_OpenCL_ATI!+0x0
      0236ffd4 77ab9ed5 00454ff0 00000000 00000000 00000000 ntdll!RtlInitializeExceptionChain+0x0
      0236ffec 00000000 00454ff0 00000000 00000000 00905a4d ntdll!RtlInitializeExceptionChain+0x0
        • HD6970 and app crashes
          himanshu.gautam

          raistmer,

          can you please provide information of the system you were working on(CPU,GPU,SDK,Catalyst and OS). What code were you trying? Can you give a test case?

          • HD6970 and app crashes
            Raistmer
            Perhaps you interesting in info for host where crash was detected, not the one where I do development.
            Host params: Catalyst 11.2, Widows 7 SP1 x64 (or Vista x64, both failed), SDK 2.3, GPU: HD6970 (written in thread title, btw), CPU unknown for now (can refine if it's really needed info).
            I can't give test case but you can download whole app: http://files.mail.ru/X3QZXF
            crash detected when 2 instances run together. If needed I can profide input data (I laready sent whole package with instructions how to run to AMD support before).

              • HD6970 and app crashes
                himanshu.gautam

                Raistmer,

                I tried running the app you pointed to above. But its instance gets completed within 1-2 seconds giving error in stderr file as:

                11:04:22 (3496): Can't open init data file - running in standalone mode
                11:04:22 (3496): Can't open init data file - running in standalone mode
                Priority of worker thread raised successfully
                Priority of process adjusted successfully, below normal priority class used
                OpenCL platform detected: Advanced Micro Devices, Inc.
                BOINC assigns 0 device, slots 0 to 0 (including) will be checked
                Used slot is 0; Error opening wufile in.dat: No such file or directory

                These lines are repeated 10 times with incrementing time stamps. It appears some input files are missing.

                But as you said you have sent complete package at AMD Support. Can you quote the TIcket ID you filed so i can check that from there.

              • HD6970 and app crashes
                Raistmer
                Ticket #1227