21 Replies Latest reply on Mar 15, 2011 1:52 PM by himanshu.gautam

    Help with GPU configuration??

    kojenku
      mixed configuration setting.

      I have two systems:

      1. Intel Core2Duo 3.0Ghz with integrated Intel graphics, Windows XP service pack 3 32-bit. How do I use OpenCL CPU device in this system?

      2. Intel Core2Duo, Nvidia graphics (OpenCL 1.0) in Vista 32-bit. How do I enable OpenCL CPU in this system? Nvidia sucks not supporting CPU devices. GPU OpenCL works just fine.

      In hardware 1, I have installed APP SDK but still don't have OpenCL

      (OpenCL.dll) in Windows system32 folder. Do I need to install any ATI graphics driver? Which one?

       

      In hardware 2 how do I install ATI driver, while preserving Nvidia.

      Can anyone let me know how? I can do C but not expert in video card configuration.

       

       

       

        • Help with GPU configuration??
          nou

          in both cases you should install APP SDK. and you should get OpenCL. but AMD don't officialy support non AMD devices.

            • Help with GPU configuration??
              laobrasuca

              if you succeed on support opencl for CPU on your config n° 2, please let me know. I've tried it too (AMD CPU, though) with no success.

                • Help with GPU configuration??
                  kojenku

                   

                  Originally posted by: laobrasuca if you succeed on support opencl for CPU on your config n° 2, please let me know. I've tried it too (AMD CPU, though) with no success.


                  Well, I have tried several times with raw installation (back up Nvidia OpenCL.dll to other folder). I got either Nvidia or ATI but not both. They do not work together in OpenCL.

                  Will setting %PATH% environment variable work? I will find out but my gut feeling is a NO.

                   

                   

                   

                    • Help with GPU configuration??
                      kojenku

                       

                      Originally posted by: kojenku
                      Originally posted by: laobrasuca if you succeed on support opencl for CPU on your config n° 2, please let me know. I've tried it too (AMD CPU, though) with no success.


                       

                      Well, I have tried several times with raw installation (back up Nvidia OpenCL.dll to other folder). I got either Nvidia or ATI but not both. They do not work together in OpenCL.

                       

                      Will setting %PATH% environment variable work? I will find out but my gut feeling is a NO.



                      As I expected, environment variable does not work. OpenCL.dll must reside in windows\system32 folder. Period. Therefore it is a question of either Nvidia or AMD, and I don't think of any way to get both to work together.

                      Maybe a virtual GPU entry is a way, which just adds a device registry name but not actual graphics functionailty.

                       

                  • Help with GPU configuration??
                    kojenku

                     

                    Originally posted by: nou in both cases you should install APP SDK. and you should get OpenCL. but AMD don't officialy support non AMD devices.

                     

                     

                    I did install APP SDK in configuration 1 but found no OpenCL.dll in Windows\system32 folder.

                    What happened?

                     

                      • Help with GPU configuration??
                        kojenku

                         

                        Originally posted by: kojenku
                        Originally posted by: nou in both cases you should install APP SDK. and you should get OpenCL. but AMD don't officialy support non AMD devices.

                         

                         

                         

                         

                         

                         

                        I did install APP SDK in configuration 1 but found no OpenCL.dll in Windows\system32 folder.

                         

                        What happened?

                         

                         

                         

                         

                        I downloaded the AMD Display drivers (OpenCL only), and install to configuration 1. Run CLInfo and display the information correctly. This is OpenCL 1.1.

                        Also in Geek3D GPUCapViewer, the identification correctly shows ATI Stream, 1 CLDevice, and which is Intel Core2Duo.

                    • Help with GPU configuration??
                      MicahVillmow
                      kojenku,
                      Is there any specific reason on why you aren't installing the Intel OpenCL SDK to run on the Intel CPU? You can get it from here:
                      http://software.intel.com/en-u...cles/intel-opencl-sdk/
                        • Help with GPU configuration??
                          kojenku

                          Intel OpenCL SDK is for Vista and Win7. In configuration 1, I am running Windows XP service pack 3, and Intel SDK is out of question.

                          AMD OpenCL in configuration 1 works just fine, except that CLInfo tells me there is not out-of-order queue.

                          Is this normal for all AMD OpenCL CPU?

                           

                           

                          • Help with GPU configuration??
                            kojenku

                             

                            Originally posted by: MicahVillmow kojenku, Is there any specific reason on why you aren't installing the Intel OpenCL SDK to run on the Intel CPU? You can get it from here: http://software.intel.com/en-u...cles/intel-opencl-sdk/


                            My configuration 1 is running windows xp sp3, but Intel SDK is for windows vista or windows 7.

                            AMD OpenCL-only driver works fine in this configuration.

                              • Help with GPU configuration??
                                kojenku

                                After a few research, I found out a possible problem in my configuration 2 hardware (Intel+Nvidia):

                                I am running 32-bit Windows Vista sp1 on configuration 2. According to my research, Windows 7 and Windows XP are friends to multiple graphics cards (heterogeneous), but Vista is not. To run multiple graphics card, all graphics card must come from the same vendor (either AMD or Nvidia, but not both).

                                I don't know if this holds true nowadays, but it is possible in my situation. My experience confirms this research in OpenCL.dll.

                                Can anyone in this forum provides some hints? Is it true no multiple heterogeneous graphics in Vista?

                                  • Help with GPU configuration??
                                    nou

                                    it is true that you can't have two different video driver on Vista. (if one driver can theoreticaly run both nVidia and AMD card then it should work)

                                    but it is not issue. as you have only one vide driver from nVidia. catalyst aren't needed for OpenCL CPU device. just install AMD APP SDK and newest nVidia driver. i suggest experiment with version of nVidia driver. as some was broken.

                                      • Help with GPU configuration??
                                        LeeHowes

                                        You shouldn't have to back up the OpenCL.dll or make two copies in the path, one copy of it in system32 should be fine. The dll only contains the ICD, no actual OpenCL runtime. The runtime will be elsewhere in the system, likely in the path, with a filename that will be added to the windows registry by the installer. atiocl.dll/atiocl64.dll is the AMD OpenCL runtime. NV's is presumably nvocl.dll or something similar, their installer should handle that.

                                        Once you have both the named vendor-specific dlls in the path, the ICD should let you select between them by querying the platforms through the API.

                                        There is no out-of-order queue in the AMD CL implementation at the moment. That may or may not change in the future depending on whether the overhead is worthwhile in the implementation.

                                          • Help with GPU configuration??
                                            kojenku

                                             

                                            Originally posted by: LeeHowes You shouldn't have to back up the OpenCL.dll or make two copies in the path, one copy of it in system32 should be fine. The dll only contains the ICD, no actual OpenCL runtime. The runtime will be elsewhere in the system, likely in the path, with a filename that will be added to the windows registry by the installer. atiocl.dll/atiocl64.dll is the AMD OpenCL runtime. NV's is presumably nvocl.dll or something similar, their installer should handle that.

                                             

                                            Once you have both the named vendor-specific dlls in the path, the ICD should let you select between them by querying the platforms through the API.

                                             

                                            There is no out-of-order queue in the AMD CL implementation at the moment. That may or may not change in the future depending on whether the overhead is worthwhile in the implementation.



                                            I have successfully done it. One Nvidia GPU and one Intel CPU as compute devices. They are correctly identified.

                                            Here is what I did:

                                            Download latest Nvidia driver (I use 266.xx. My previous version 196.xx).

                                            Uninstall Nvidia driver. Remove all the traces of Nvidia files in file system and registry.

                                            Reboot.

                                            Install 266.xx driver. Reboot.

                                            Install AMD APP SDK.

                                            Run CLInfo.

                                            The old version of Nvidia driver obviously has problems.

                                            Thanks LeeHowes.

                                             

                                              • Help with GPU configuration??
                                                LeeHowes

                                                I did hear that there were some bugs in some versions of the ICD, so that could explain it.

                                                Glad you got it working.

                                                • Help with GPU configuration??
                                                  laobrasuca

                                                  hey kojenku, are you able to use CPU + GPU (config 2) when using GL/CL iterop? I'm also able to use CPU+GPU but when using pure CL context only (or if I use CPU+GPU from a same platform). Do your devices appear in a single platform (config 2)?

                                                    • Help with GPU configuration??
                                                      himanshu.gautam

                                                      hi laobrasuca,

                                                      Can you provide your system configuration and the problem you are facing in more datail. It would be better to start a new topic.

                                                      Thanks.

                                                        • Help with GPU configuration??
                                                          laobrasuca

                                                          hi himanshu,

                                                          yes, it would be cleaner, indeed. Maybe we could also have a fixed post on this GL/CL interop matter, at least on what concerns the system setup. There's too many posts out there, which makes us a little lost.

                                                          Well, my system is AMD CPU (Phenom II X4 965), AMD/ATI GPU (Radeon HD 5870), NVIDIA GPU (Geforce GTX 460/1GB), Win7 Pro x64 and most recent drivers/SDKs. I've been successful on using these GPUs individually for GL/CL iterop without switching hardware and reboots. However, I'm not successful on using both GPU at the same time on CL/GL and i'm not successful on using CPU CL + NVIDIA GPU on GL/CL iterop neither (only on pure CL context). I'll write a more detailed post when I'll have a bit more of time (probably by the moon light).

                                                            • Help with GPU configuration??
                                                              himanshu.gautam

                                                               

                                                              Originally posted by: laobrasuca hi himanshu,

                                                              However, I'm not successful on using both GPU at the same time on CL/GL and i'm not successful on using CPU CL + NVIDIA GPU on GL/CL iterop neither (only on pure CL context). I'll write a more detailed post when I'll have a bit more of time (probably by the moon light).

                                                              Are you trying to do CL\GL interop taking AMD GPU and NVIDIA GPU together. How do you fit them inside a single context?

                                                               Surely a better explanation of your experiments would be better.