4 Replies Latest reply on Feb 18, 2011 2:30 AM by nomac

    ATI Stream SDK 2.3 on Linux and AMD Opteron 2356 CPU

    nomac

      Hello,

      I just tried to get the ATI Stream SDK 2.3 running in a Linux environment on hosts with two AMD Opteron 2356 CPUs.

      I did follow the instructions (which worked on other machines) and did the ICD registration etc.

      Anyhow, it does not work. The error implies some problems with die ICD registration, but all the files are on their expted place in /etc/OpenCL/vendors.

      From the HelloCL-example, I get:

      HelloCL!
      Getting Platform Information
      Platform::get() failed (-1001)

      CLInfo results in:

      terminate called after throwing an instance of 'cl::Error'
        what():  clGetPlatformIDs
      Aborted

      The system is 64 Bit, but I tried also tried 32 Bit (with the according libraries) which made no difference at all.

      One possibility could be that the CPU is not supported. But this seems not very likely as it supports SSE, SSE2, and SSE4a (according to /proc/cpuinfo). Surprisingly there is no support for SSE3 stated. But the SDK runs with SSE2 on an old Pentium-M of mine.

      Maybe there are some undocumented dependencies which could be broken?

      Any ideas?