tvsingh

Problem installing the ATI Stream 2.3

Discussion created by tvsingh on Jan 21, 2011
Latest reply on Mar 26, 2011 by himanshu.gautam
CAL version mismatch: This OpenCL build requires version 1.4.879, version 1.4.815 installed.

I have a system with Intel E8600 processors. I have installed only GPU device Firepro v9800 ATI card in it. 

These are the details of software stacks:

OS: centOS 5.5 (Final)

Kernel: 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:52:25 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI FirePro V9800 (FireGL)
OpenGL version string: 4.0.10219 Compatibility Profile Context FireGL

fglrc version: 8773.1

SDK: ati-stream-sdk-v2.3-lnx64

 

After installing fglrx, aticonfig lists one GPU device correctly. fglrxinfo lists the device correctly. 

But when I compile the samples from cal and opencl, cal's FindNumDevices returns the following output:

/FindNumDevices
Supported CAL Runtime Version: 1.3.185
Found CAL Runtime Version: 1.4.815
Use -? for help
CAL initialized.
Finding out number of devices :-
Device Count = 1
CAL shutdown successful.

Whereas CLinfo from opencl returns the follo./CLInfo
*** CAL version mismatch:
This OpenCL build requires version 1.4.879, version 1.4.815 installed.
Aborting.
Number of platforms:                             1
  Platform Profile:                              FULL_PROFILE
  Platform Version:                              OpenCL 1.1 ATI-Stream-v2.3 (451)
  Platform Name:                                 ATI Stream
  Platform Vendor:                               Advanced Micro Devices, Inc.
  Platform Extensions:                           cl_khr_icd cl_amd_event_callback cl_amd_offline_devices
wing:

 

which does not include any GPU device. I have been struggling to get it working with 2.3 whereas it was working with 2.2 version of sdk.

The problem with 2.2 was that it was assuming Firepro9800 to be FirePro5800, therefore I am trying to upgrade to 2.3 assuming the problem might have been resolved.

Any help in getting it work will be appreciated!

Thanks in advance,

TV

 

 

 

 

Outcomes