29 Replies Latest reply on Mar 26, 2011 10:45 AM by himanshu.gautam

    Problem installing the ATI Stream 2.3

    tvsingh
      CAL version mismatch: This OpenCL build requires version 1.4.879, version 1.4.815 installed.

      I have a system with Intel E8600 processors. I have installed only GPU device Firepro v9800 ATI card in it. 

      These are the details of software stacks:

      OS: centOS 5.5 (Final)

      Kernel: 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:52:25 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

      fglrxinfo
      display: :0.0  screen: 0
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: ATI FirePro V9800 (FireGL)
      OpenGL version string: 4.0.10219 Compatibility Profile Context FireGL

      fglrc version: 8773.1

      SDK: ati-stream-sdk-v2.3-lnx64

       

      After installing fglrx, aticonfig lists one GPU device correctly. fglrxinfo lists the device correctly. 

      But when I compile the samples from cal and opencl, cal's FindNumDevices returns the following output:

      /FindNumDevices
      Supported CAL Runtime Version: 1.3.185
      Found CAL Runtime Version: 1.4.815
      Use -? for help
      CAL initialized.
      Finding out number of devices :-
      Device Count = 1
      CAL shutdown successful.

      Whereas CLinfo from opencl returns the follo./CLInfo
      *** CAL version mismatch:
      This OpenCL build requires version 1.4.879, version 1.4.815 installed.
      Aborting.
      Number of platforms:                             1
        Platform Profile:                              FULL_PROFILE
        Platform Version:                              OpenCL 1.1 ATI-Stream-v2.3 (451)
        Platform Name:                                 ATI Stream
        Platform Vendor:                               Advanced Micro Devices, Inc.
        Platform Extensions:                           cl_khr_icd cl_amd_event_callback cl_amd_offline_devices
      wing:

       

      which does not include any GPU device. I have been struggling to get it working with 2.3 whereas it was working with 2.2 version of sdk.

      The problem with 2.2 was that it was assuming Firepro9800 to be FirePro5800, therefore I am trying to upgrade to 2.3 assuming the problem might have been resolved.

      Any help in getting it work will be appreciated!

      Thanks in advance,

      TV

       

       

       

       

        • Problem installing the ATI Stream 2.3
          MicahVillmow
          Your fire GL driver is not new enough to use SDK 2.3, please contact your FireGL vendor to get update drivers for SDK 2.3 if you can't use the standard catalyst.
          • Problem installing the ATI Stream 2.3
            MicahVillmow
            Ahh ok, I am not that familiar with the FirePro/FireGL lines. Basically the problem is that your driver isn't new enough to work with SDK 2.3.

            One thing that you can try is to install the most recent catalyst driver and get the atical*.dll from system32 and syswow64 and then reinstall your FirePro/FireGL driver. I can't guarantee that this will work, but those are the DLL's that you need to run SDK 2.3.
              • Problem installing the ATI Stream 2.3
                tvsingh

                Thanks Micah,

                I am sorry but I downloaded the latest driver for my current operating system today morning from ADM's site. The release date is  12/10 and that is the only driver I could find at AMD's support site.

                By the way my system is CentOS 5.5 Linux and not Microsoft windows system where dll will work.

                Thanks again,

                TV

                 

                 

                NameFile SizeRevision NumberRelease
                Date
                Download
                Link
                ATI FirePro/GL/MV Software Suite Multilanguage97.6 MB8.773.112/20/2010Download
                Description:
                Package Includes:
                Display Driver
                OpenCL Runtime
                DisplayPort and HDMI audio driver
                ATI Catalyst Control Center (Multi-Language)
              • Problem installing the ATI Stream 2.3
                MicahVillmow
                Then you should be able to get the libatical*.so files from the catalyst driver and replace the ones that exist already in /usr/bin and /usr/bin[64|32]

                Basically the FirePro/GL/MV base driver is older than the catalyst driver and therefor the CAL DLL's in that driver is older, so you need to get newer CAL DLL's to work with SDK 2.3.

                Now this isn't the 'official' way to do things, so use it at your own risk. I would also contact the AMD FirePro team about getting a newer driver with SDK 2.3 support.
                  • Problem installing the ATI Stream 2.3
                    tvsingh

                    Thanks Micah,

                     

                    Yes I can do this. But I only have the libatcal*.so files that came with the driver and I can not find the newer version for them.

                    > I would also contact the AMD FirePro team about getting a newer driver with SDK 2.3 support.

                    I also think that is "the" problem. Looks like there is a driver which is not yet out and SDK 2.3 is using it. So please add my request for its release if it can be done or any pointer to it will also do the trick.

                    Thanks again,

                    TV

                     

                  • Problem installing the ATI Stream 2.3
                    MicahVillmow
                    tvsingh,
                    I have let the product manager know about the driver not working. There should be a linux driver in the beta section of the driver download show up in the next few days. That being said, the V9800 is not 'officially' supported by the SDK, so you might see some issues.
                    • Problem installing the ATI Stream 2.3
                      MicahVillmow
                      tvsingh,
                      I was told today that the linux driver has been uploaded correctly.
                        • Problem installing the ATI Stream 2.3
                          tvsingh

                          Thank you Micah,

                           

                          I installed it and the problem related to CAL version mismatch went away and infact the OpenCL code runs.

                          But still I do not see the right device level information as output to CLInfo, which as you suggested may be due to the device not supported in the sdk.

                           

                          Thanks again for the help,

                          TV

                            • Problem installing the ATI Stream 2.3
                              abstractius

                              Well, I have the same problems on Windows 7 x64, with mobility HD5650. Catalyst was updated last week, but it does not offer any new driver on my system, and I get mismatches. I am dual-booting Ubuntu as well, but haven't tried with the newest driver yet. But it does make me wonder WHAT platform are these releases tested on, I can't remember a version that was running out of the box on both Windows and Linux!

                                • Problem installing the ATI Stream 2.3
                                  himanshu.gautam

                                  abstractius,

                                  Are you saying you are not even able to run opencl samples with SDK 2.3 and catalyst 11.1 with your 5670 on Win7?

                                  The tested drivers page is http://developer.amd.com/gpu/AMDAPPSDK/downloads/Pages/default.aspx#one

                                   

                                    • Problem installing the ATI Stream 2.3
                                      abstractius

                                      Yes himanshu, I had the mismatch problems even on my "well supported" platform, anyway with the catalyst released this week I am out of this problem, and into several new ones it seems.

                                        • Problem installing the ATI Stream 2.3
                                          himanshu.gautam

                                          abstractius,

                                          Can you provide details about the problem you are facing? Win 7, i guess is a high priority platform and thorough testing is done for that.

                                          Its good to hear that your mismatch issue was resolved with the new driver. Generally such issues occur due to errorneous or imcomplete driver uninstallation.

                                            • Problem installing the ATI Stream 2.3
                                              abstractius

                                              Maybe my worldview is distorted, but it is up to AMD to include smarter error messages, automatically linking to correct versions, or even an install-on-demand mechanism. If experienced developers need to find some workaround or unique correct procedure for installation then there is something wrong with the installer.

                                              Most busy people will cut their losses at some stage, and instead of wasting time trying to prepare a reasonable post after searching through the forum etc. they will simply take a break and wait for the next versions, if not give up on the platform completely. I did post another thread relating some further superficial experiences, they are all impediments towards deeper involvement.

                                                • Problem installing the ATI Stream 2.3
                                                  fotis

                                                  Same problem here. Windows 7 64bit and Firepro v4800.

                                                  Driver information:

                                                  Driver Packaging Version    8.773-100907a-105602C   
                                                  Provider    ATI Technologies Inc.   
                                                  2D Driver Version    8.01.01.1071   
                                                  2D Driver File Path    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000   
                                                  Direct3D Version    8.14.10.0779   
                                                  OpenGL Version    6.14.10.10207   
                                                  Catalyst Control Center Version    2011.0126.1749.31909

                                                  FindNumDevices output:

                                                  Supported CAL Runtime Version: 1.3.185
                                                  Found CAL Runtime Version: 1.4.815
                                                  Use -? for help
                                                  CAL initialized.
                                                  Finding out number of devices :-
                                                  Device Count = 1
                                                  CAL shutdown successful.

                                                  Typical output:

                                                  *** CAL version mismatch:
                                                  This OpenCL build requires version 1.4.879, version 1.4.815 installed.
                                                  Aborting.

                                                   

                                                   

                                                    • Problem installing the ATI Stream 2.3
                                                      himanshu.gautam

                                                      fotis,

                                                      Your findnumdevices show that you have one GPU device detected.

                                                      When do you get the last output? Such errors generally occur when the previous driver was not uninstalled completely. You can use driver sweeper before installing a new driver version.

                                                      Thanks

                                                       

                                                        • Problem installing the ATI Stream 2.3
                                                          fotis

                                                          Thank you for your interest, himanshu.gautam.

                                                           

                                                          Originally posted by: himanshu.gautam

                                                          Your findnumdevices show that you have one GPU device detected.



                                                          Indeed I have only one GPU device installed, namely the Firepro v4800.

                                                           

                                                          Such errors generally occur when the previous driver was not uninstalled completely. You can use driver sweeper before installing a new driver version.


                                                          So I have to uninstall/reinstall the drivers?

                                                          Thanks

                                                           

                                                            • Problem installing the ATI Stream 2.3
                                                              fotis

                                                              No luck, problem insists.


                                                              setup:

                                                              Windows 7 x64

                                                              Firepro v4800.

                                                              Drivers: FirePro_8.773.1.1_Win7x64_112278

                                                              SDK: streamsdk_2-3_win764


                                                              FindNumDevices output:

                                                              Supported CAL Runtime Version: 1.3.185
                                                              Found CAL Runtime Version: 1.4.815
                                                              Use -? for help
                                                              CAL initialized.
                                                              Finding out number of devices :-
                                                              Device Count = 1
                                                              CAL shutdown successful.

                                                               


                                                              clinfo output:

                                                              *** CAL version mismatch:
                                                              This OpenCL build requires version 1.4.879, version 1.4.815 installed.
                                                              Aborting.
                                                              Number of platforms:                             1
                                                                Platform Profile:                              FULL_PROFILE
                                                                Platform Version:                              OpenCL 1.1 ATI-Stream-v2.3 (451
                                                              )
                                                                Platform Name:                                 ATI Stream
                                                                Platform Vendor:                               Advanced Micro Devices, Inc.
                                                                Platform Extensions:                           cl_khr_icd cl_amd_event_callbac
                                                              k cl_amd_offline_devices cl_khr_d3d10_sharing


                                                                Platform Name:                                 ATI Stream
                                                              Number of devices:                               1
                                                                Device Type:                                   CL_DEVICE_TYPE_CPU
                                                                Device ID:                                     4098
                                                                Max compute units:                             6
                                                                Max work items dimensions:                     3
                                                                  Max work items[0]:                           1024
                                                                  Max work items[1]:                           1024
                                                                  Max work items[2]:                           1024
                                                                Max work group size:                           1024
                                                                Preferred vector width char:                   16
                                                                Preferred vector width short:                  8
                                                                Preferred vector width int:                    4
                                                                Preferred vector width long:                   2
                                                                Preferred vector width float:                  4
                                                                Preferred vector width double:                 0
                                                                Native vector width char:                      16
                                                                Native vector width short:                     8
                                                                Native vector width int:                       4
                                                                Native vector width long:                      2
                                                                Native vector width float:                     4
                                                                Native vector width double:                    0
                                                                Max clock frequency:                           3214Mhz
                                                                Address bits:                                  64
                                                                Max memory allocation:                         1073741824
                                                                Image support:                                 No
                                                                Max size of kernel argument:                   4096
                                                                Alignment (bits) of base address:              1024
                                                                Minimum alignment (bytes) for any datatype:    128
                                                                Single precision floating point capability
                                                                  Denorms:                                     Yes
                                                                  Quiet NaNs:                                  Yes
                                                                  Round to nearest even:                       Yes
                                                                  Round to zero:                               Yes
                                                                  Round to +ve and infinity:                   Yes
                                                                  IEEE754-2008 fused multiply-add:             No
                                                                Cache type:                                    Read/Write
                                                                Cache line size:                               64
                                                                Cache size:                                    65536
                                                                Global memory size:                            3221225472
                                                                Constant buffer size:                          65536
                                                                Max number of constant args:                   8
                                                                Local memory type:                             Global
                                                                Local memory size:                             32768
                                                                Kernel Preferred work group size multiple:     1
                                                                Error correction support:                      0
                                                                Unified memory for Host and Device:            1
                                                                Profiling timer resolution:                    318
                                                                Device endianess:                              Little
                                                                Available:                                     Yes
                                                                Compiler available:                            Yes
                                                                Execution capabilities:
                                                                  Execute OpenCL kernels:                      Yes
                                                                  Execute native function:                     Yes
                                                                Queue properties:
                                                                  Out-of-Order:                                No
                                                                  Profiling :                                  Yes
                                                                Platform ID:                                   00000000013E9568
                                                                Name:                                          AMD Phenom(tm) II X6 1090T Proc
                                                              essor
                                                                Vendor:                                        AuthenticAMD
                                                                Driver version:                                2.0
                                                                Profile:                                       FULL_PROFILE
                                                                Version:                                       OpenCL 1.1 ATI-Stream-v2.3 (451
                                                              )
                                                                Extensions:                                    cl_amd_fp64 cl_khr_global_int32
                                                              _base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomi
                                                              cs cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_ex
                                                              tended_atomics cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_device_fis
                                                              sion cl_amd_device_attribute_query cl_amd_media_ops cl_amd_popcnt cl_amd_printf
                                                              cl_khr_d3d10_sharing


                                                              Any help?

                                                                • Problem installing the ATI Stream 2.3
                                                                  himanshu.gautam

                                                                  Your CAL output ensures that driver is installed properly. I do not have the said GPU, so will ask someone else.

                                                                  Is there anyone else who has this configuration working/not-working?

                                                                  fotis,

                                                                  Can you tell the driver you tried?

                                                                   

                                                                  EDIT: Do you still face the CAL version mismatch error?

                                                                    • Problem installing the ATI Stream 2.3
                                                                      fotis

                                                                      The driver info as shown in CCC, is as follows:

                                                                      Driver Packaging Version    8.773.1.1-110115a-112278C   
                                                                      Provider    ATI Technologies Inc.   
                                                                      2D Driver Version    8.01.01.1071   
                                                                      2D Driver File Path    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000   
                                                                      Direct3D Version    8.14.10.0779   
                                                                      OpenGL Version    6.14.10.10225   
                                                                      Catalyst™ Control Center Version    2011.0115.2247.40819   

                                                                        • Problem installing the ATI Stream 2.3
                                                                          himanshu.gautam

                                                                          hi fotis,

                                                                          Thanks for the detailed information. I previously asked when do you get the CAL mismatch error. Does it still happen?

                                                                          If it doesn't happen you have installed the driver properly. Try uninstall/reinstall of the stream SDK as this could be the problem in the later case.

                                                                            • Problem installing the ATI Stream 2.3
                                                                              fotis

                                                                              Yes it still happens. (I have already uninstalled/reinstalled the SDK).

                                                                              Output of OpenCl samples/ HelloCL:


                                                                              HelloCL!
                                                                              Getting Platform Information
                                                                              *** CAL version mismatch:
                                                                              This OpenCL build requires version 1.4.879, version 1.4.815 installed.
                                                                              Aborting.
                                                                              Creating a context AMD platform
                                                                              Getting device info
                                                                              Loading and compiling CL source
                                                                              Running CL program
                                                                              Done
                                                                              Passed!
                                                                              Press any key to continue . . .

                                                                               

                                                                               

                                                                        • Problem installing the ATI Stream 2.3
                                                                          ramandeep

                                                                           

                                                                          Hi Fotis,

                                                                           

                                                                          It seems like your cal dll's are not uninstalling properly. Please uninstall the driver, after that run driver sweeper (which will delete all the cal dll's) & than reboot & then install the latest driver. Hope this will fix your problem.

                                                                          --

                                                                          Ramandeep



                                                                            • Problem installing the ATI Stream 2.3
                                                                              fotis

                                                                              I have already done this twice, for both the driver and the sdk.

                                                                              Uninstall -> Boot into safe mode -> Driver sweeper -> Reinstall.

                                                                              Nothing changed.

                                                                                • Problem installing the ATI Stream 2.3
                                                                                  genaganna

                                                                                   

                                                                                  Originally posted by: fotis I have already done this twice, for both the driver and the sdk.

                                                                                   

                                                                                  Uninstall -> Boot into safe mode -> Driver sweeper -> Reinstall.

                                                                                   

                                                                                  Nothing changed.

                                                                                   

                                                                                  Fotis,

                                                                                           Please try with latest driver. You can download this driver from following location.

                                                                                           http://support.amd.com/us/gpudownload/fire/Pages/fire_beta_win7-64.aspx

                                                                                    • Problem installing the ATI Stream 2.3
                                                                                      fotis

                                                                                      Hi genaganna.

                                                                                      Thank you very much for your help; unfortunately I do not want to try the beta drivers since this is a production machine.

                                                                                      I regret to say that it has been almost a year after the release of this "professional" card and it is unusable, concerning the sdk on the #1 priority platfrorm.

                                                                                      In Linux (Ubuntu 10.10) I have the same problems as the OP. However I cannot upgrade the drivers (as the GP did and solved his problem) due to an X Server unable to detect problem. I suppose I should start another topic for that too.

                                                                                      Finally ACML-GPU seems not to working reasonably, but I suppose this might have to do with the faulty drivers. Anyway I'll start another topic for that too.

                                                                                      That's all for that premium card.

                                                                                      Thank you for your answers.

                                                                                • Problem installing the ATI Stream 2.3
                                                                                  dragonxi4amd

                                                                                  Hi,

                                                                                  Solution for your problem would be easier to find if AMD provided information about its OpenCL SDK in the same way as CLInfo tries to give us some hint about platform, GPU and CPU: 

                                                                                  After downloading and installing the new AMD utility coud provide/check/advice about:

                                                                                  1. required software / components/drivers/DLLs ... for AMD SDK

                                                                                  2. installed software/ components and their versions

                                                                                  3. required settings in the system after installation

                                                                                  I had challenges to get AMD SDK OpenGL demo to work with  CAL 1.4.900, OpenCL 1.0 ATI-Stream-v2.3 ,  ATi Radeon HD 4800  ,

                                                                                  cal_d3d_interop.cpp worked printing:  Supported CAL Runtime Version: 1.3.185 - Found 1.4.900 but I had to advice MS Studio to use Windows

                                                                                  7 OpenGL components !

                                                                                  I now have the problem to get AMD SDK DirectX demo to work and

                                                                                  the reason I tell to you is that we might share the same problems:

                                                                                  a) CLInfo does not necessary help !

                                                                                  b) AMD could provide version information about AMD OpenCL SDK itself

                                                                                  - installed, supported, discovered, analyzed version

                                                                                  The (too often got ) advice to uninstall and reinstall AMD SDK seldom works

                                                                                  and might install old components from other vendor, therefore

                                                                                  c) having just bare/core OpenCL SDK from AMD without components from other vendors might help not only me but also you !

                                                                                  Sorry I could not provide you the solution - AMD most propably has - I myself is trying to get AMD SDK Direct X example to work, provided info CLInfo but it might have helped AMD developers if I had had an AMD program displaying

                                                                                  - even analyzed - more about components and versions found and required for the cal_d3d10_interop.cpp to work !

                                                                                   

                                                                                   

                                                                                   

                                                                                   

                                                                                   

                                                                                   

                                                                                   

                                                                                    • Problem installing the ATI Stream 2.3
                                                                                      himanshu.gautam

                                                                                      dragonxi4amd,

                                                                                      Thanks for sending all these feedbacks about installation problems.

                                                                                      I recommend you to go through the installation guide which is available at the SDK Documentation page.

                                                                                      We are constantly improving our documentation support and hope you would expect some good improvements in the new documentation which would be available with the new SDK release.

                                                                                      Feel free to give suggestions.

                                                                                      Thanks