0 Replies Latest reply on Oct 4, 2010 8:27 AM by wipamit

    Linpack crashes with ACML on Windows Server 2008 R2

    wipamit

      I have built HPL with acml library version 4.4.0 for Win64 platform. I am launching HPL with mpirun.

      It is working fine on Windows Server 2003 and Windows Server 2008.

      But when i am launching it in similar way in Windows Server 2008 R2 edition, my application crashes and shows the below message:

       

       

      Problem Event Name: APPCRASH

      Application Name:       xhpl.exe

      Application Version:    0.0.0.0

      Application Timestamp:             4ca282c5

      Fault Module Name:    libacml_dll.dll

      Fault Module Version:  0.0.0.0

      Fault Module Timestamp:           44ace398

      Exception Code:           c0000005

      Exception Offset:          00000000008869a6

      OS Version:      6.0.6002.2.2.0.274.10

      Locale ID:        1033

      Additional Information 1:           a943

      Additional Information 2:           e35e2ad1c18333c6de41ebbe1a60bd16

      Additional Information 3:           ef67

      Additional Information 4:           2dd746bb053aa615d01ff351a54ba121

       

      I am able to reproduce it by executing the following statement in a .bat file:

      bin\mpirun.exe  -np 2  -stdio=bline,r3,p hpLinpackACML.exe

      Just to verify if mpirun is working fine, i changed the value of -np to 1 in place of 2.

      Is there a multithreading issue with ACML library. May be some in compatibility with Windows Server 2008 R2 edition.

      Please update.

      Thanks in Advance