16 Replies Latest reply on Sep 16, 2010 10:09 PM by MicahVillmow

    SDK 2.2 installer bug

    bubu

       When I install the ATI Stream Profiler "installation wizard" says "Searching for installed applications"... and takes forever.

       

      I'm using W7 x64 Home Premium, VS2008 SP1/VS2010, a Radeon 5750 and Cat 10.7

      thx

        • SDK 2.2 installer bug
          ryta1203

          The install for the profiler for me took forever too; however, it's profiler 1.4 right? Are you thinking of the SKA? Cuz that is 1.6.

            • SDK 2.2 installer bug
              bubu

               

              Originally posted by: ryta1203 The install for the profiler for me took forever too; however, it's profiler 1.4 right? Are you thinking of the SKA? Cuz that is 1.6.

               

              My fault, I was confusing it with the SKA, sorry.

              But, yep, takes forever. It's bugged.

                • SDK 2.2 installer bug
                  ryta1203

                  Don't even bothering installing 2.2 or 10.7. My kernels (along with some samples) have taken a large GPR hit with the "new" SDK/Drivers.

                  I'm not sure whether this was done on purpose by AMD or not (can't see why it would be though).

              • SDK 2.2 installer bug
                MicahVillmow
                Ryta,
                Can you provide some sample test cases to streamdeveloper@amd.com showing this issue?
                  • SDK 2.2 installer bug
                    ryta1203

                    BlackScholes sample SDK.

                    The first ISA is from SDK 2.1

                    The second ISA is from SDK 2.2

                    Why was the GPR increased? Does this have anything to do with the cache?

                     I also notice that the stack size has changed? Is this to increase performance?

                    ;SQ_PGM_RESOURCES = 0x30000110 SQ_PGM_RESOURCES:NUM_GPRS = 16 SQ_PGM_RESOURCES:STACK_SIZE = 1 SQ_PGM_RESOURCES:PRIME_CACHE_ENABLE = 1 ;SQ_PGM_RESOURCES_2 = 0x000000C0 SQ_LDS_ALLOC:SIZE = 0x00000000 ; RatOpIsUsed = 0x2 ; NumThreadPerGroupFlattened = 256 ; SetBufferForNumGroup = true ;SQ_PGM_RESOURCES = 0x3000001F SQ_PGM_RESOURCES:NUM_GPRS = 31 SQ_PGM_RESOURCES:STACK_SIZE = 0 SQ_PGM_RESOURCES:PRIME_CACHE_ENABLE = 1 ;SQ_PGM_RESOURCES_2 = 0x000000C0 SQ_LDS_ALLOC:SIZE = 0x00000000 ; RatOpIsUsed = 0x2 ; NumThreadPerGroupFlattened = 256 ; SetBufferForNumGroup = true

                    • SDK 2.2 installer bug
                      ryta1203

                       

                      Originally posted by: MicahVillmow Ryta, Can you provide some sample test cases to streamdeveloper@amd.com showing this issue?


                      I must be missing something. If you could just verify that this is incorrect or not that would be great, should be simple since I just used one of your own samples.

                    • SDK 2.2 installer bug
                      MicahVillmow
                      Ok, thanks I'll take a look into this.
                        • SDK 2.2 installer bug
                          bubu

                           

                          Originally posted by: MicahVillmow Ok, thanks I'll take a look into this.


                          I'm referring to the installer btw. I simply cannot install the ATI Stram Profiler 1.4 because the installer takes forever "Searching for installed applications..."

                          • SDK 2.2 installer bug
                            bpurnomo

                            ATI Stream Profiler 1.4 does take a while to install now (~10 minutes on our systems here---the second install is much faster though).  It performs some initial setups and registers the plugin with Visual Studio during that time.  We are looking for ways to speed up this process.  Thank you for the feedback.

                            • SDK 2.2 installer bug
                              ryta1203

                               

                              Originally posted by: MicahVillmow Ok, thanks I'll take a look into this.


                              Micah,

                                You can also look at the Mersenne Twister example. The GPR went from 31 to 51 and performance dropped significantly.

                                I have a ton of work to do and I just want to know if I should drop back to what I was using before (10.5 and SDK 2.1)? So the sooner you can let us know the better, thank you.

                                • SDK 2.2 installer bug
                                  ryta1203

                                  Bump.

                                  As I am still waiting for an answer and I didn't want it to get lost off page 1.

                                    • SDK 2.2 installer bug
                                      genaganna

                                       

                                      Originally posted by: ryta1203 Bump.

                                       

                                      As I am still waiting for an answer and I didn't want it to get lost off page 1.

                                       

                                      We observed performance improvement/dips in few samples.

                                      I have reported to developers.  I will get back to you.

                                        • SDK 2.2 installer bug
                                          ryta1203

                                          Ok, thank you.

                                          It's really the register allocation. It's confusing that some optimizations would make the register usage go from 31 to 51 (+20!!).

                                          Seems odd.

                                          I look forward to the response. In the meantime I'm going back to the more stable and predictable and better 2.1 and catalyst 10.5.

                                            • SDK 2.2 installer bug
                                              bubu

                                              Wonderful. I've noticed that, after cancelling the ATI Stream Profiler's installer, all the VS2008's application wizards are all broken.

                                              Now I have to reinstall all the Visual Studio again...

                                                • SDK 2.2 installer bug
                                                  genaganna

                                                   

                                                  Originally posted by: bubu Wonderful. I've noticed that, after cancelling the ATI Stream Profiler's installer, all the VS2008's application wizards are all broken.

                                                   

                                                  Now I have to reinstall all the Visual Studio again...

                                                   

                                                  Please give us VS2008 details. Is VS2008 running while installing SDK?

                                      • SDK 2.2 installer bug
                                        MicahVillmow
                                        Ryta,
                                        The register allocation issue has been fixed and should be ready for the next SDK release. One of our internal test cases went from 62 registers down to 28.