4 Replies Latest reply on Aug 13, 2010 3:25 PM by Grunt

    ATI Memory Viewer

    Grunt
      Not working.

      The ATI Memory Viewer at http://www.amd.com/us/products/workstation/graphics/tools/pages/tools.aspx does not work (constant un-updated reading) with 10.7 and perhaps other versions too. Is anyone aware of this problem and a possible fix?

      Thanks.

        • ATI Memory Viewer
          Byron

          can you provide more details, OS & graphics card?

            • ATI Memory Viewer
              Grunt

              Hi Byron,

              The card was a HIS 5450 DDR3 1GB and tried on Windows VHP 32-bit and W7HP 64-bit. ATi catalyst 10.3 and 10-7, stream sdk 2.1. Two other users also said the memory reading was fixed when they tried the software on their systems whatever they were.

              I also tried the OGL ATI_meminfo

                      VBO_FREE_MEMORY_ATI                      =  0x87FB
                      TEXTURE_FREE_MEMORY_ATI               =  0x87FC
                      RENDERBUFFER_FREE_MEMORY_ATI     =  0x87FD 

              and they returned the same unchanging reading ~34MB of used memory so maybe a driver problem. In fact all 4 returned values were fixed/unchanging regardless of load. I kind of gave up at that stage. If it gets fixed sometime I may give it another go but for now I've switched back to using nVidia.

                • ATI Memory Viewer
                  Byron

                  the tool only works on Windows XP, Vista/Win7 have drastically different driver models (our gfx driver no longer does it's own memory allocation), so we currently do not have a comparable solution for Win7 at present. 

                  As the tool uses the ATI_meminfo interface, the tool or other code based on this interface will not work with Win7